[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

getOutputFrom(): Broken pipe



Hi,

I just switched from RedHat 7.x to RedHat 8.0. Now I have problems creating an rpm-file.
What I want to do is just pack some directory tree located under /some-path into an rpm
package, and when the rpm is installed the files should be put at exactly the same path.
Up to now it worked by specifying the complete path of all files to be packed in the %files
section. With the rpm version from RedHat 8.0 it seems that rpmbuild requires a buildroot
to be set. After rpmbuild tried to execute check-files I get the following error message:

getOutputFrom(): Broken pipe

I have seen that check-files first checks whether the buildroot given as $1 exists.
$1 is in my case %{buildroot} because I have not specified one. Thus check-files terminates
with exit 1. I already tried to add an entry to ~/.rpmmacros to use another script for
check-files which does nothing, or maybe only prints out something stupid. rpmbuild executed
this script, but after that it still terminates with the above error message.

Any idea how to package my files without having to copy them to some buildroot directory?
The files I want to pack are just a subset of all files under /some-path. Copying the
whole directory to a buildroot directory would cost to much time and space. For copying only
the files mentioned in the %files section it seems that I would need to write a script, and
even copying only these files would take quite some time and cost some disk space.


Kind regards,


Michael






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []