[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: How to abort RPM upgrade if previous package is at inappropriateversion?



> >> Here's what I want to do:
> >> Create an RPM that refuses to install/upgrade if there already exists
> >> the same package of a certain version (or earlier).
> >> 
> 
> > Um, what's wrong with
> >     Conflicts: foo <= 1.2
> > substituting for "foo" and "1.2" as appropriate?
> 
> Package foo version 2.1.0-8 installed on system.
> Spec file contains "Conflicts: foo < 2.5.0.-0"

This should read   Spec file contains "Conflicts: foo < 2.5.0-0"
Sorry.

> Package foo version 2.5.1-0 upgrades cleanly (grrr).
> 
> Does the check for conflicts also consider the
> version of the package that is currently being
> installed?  If so, wouldn't that explain why the
> conflict was resolved?

Suzan Wassman   suz@speakeasy.org
http://www.speakeasy.org/~suz/





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []