[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RPM 4.2-066 is failing compile on Solaris 8 looking for libz



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Saturday February 08, 2003 09:06 pm, Donnie Cranford wrote:
> When it fails here is the ouput
>
> /usr/local/bin/gcc -I/usr/local/include -I/usr/local/BerkeleyDB/include
> -I/opt/sfw/include -I/opt/sfw/include/db1 -I/opt/sfw/include/db3
> -I/usr/include -I/usr/openwin/include -D_GNU_SOURCE -D_REENTRANT -Wall
> -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes
> -Wno-char-subscripts -o file -static file.o  ./.libs/libfmagic.al -lz
> ld: fatal: library -lz: not found

This doesn't look like an rpm error at all.

The compiler is trying to link with zlib, but apparently you haven't installed 
it. How does this mean rpm doesn't work or fails to compile? I don't think it 
means either of those. I think it means you don't have the required 
libraries, and don't know what an error looks like when you haven't got these 
libraries installed and try to build it anyway.

Install zlib and try again.

- -- 
Sincerely,

David Walluck
<david@anti-microsoft.org>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.1 (GNU/Linux)

iD8DBQE+Rb8YJB7s/tlHKVIRAsgSAJoDuDaONfNeMz02aVSvBvjZEELoZwCdHTYc
SFIJJBQJ7kOlNHTxUnIRArw=
=eOzb
-----END PGP SIGNATURE-----





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []