[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Fwd: /sbin/sh dependency error with rpm]



Hello,

Also what should I install if I should not get dependency error
for libncurses.so.4
error: failed dependencies:
                     libncurses.so.4

Regs,
Manjula

--- Begin Message ---
Hello,

Thanks,
It worked..I had a script which was using /sbin/sh.
Changing it to /bin/sh worked.

Regs,
Manjula

Valery Reznic wrote:

> --- Manjula <mramacha@cisco.com> wrote:
> > Hello,
> >
> > I have created a rpm package. But when I try to
> > install it,
> > it gives the following error.
> >
> > [root@test1 i386]# rpm -i test-2.0-B16.i386.rpm
> > error: failed dependencies:
> >         /sbin/sh   is needed by test-2.0-B16
> >
> > If I install with "--nodeps" option, installation
> > goes through properly.
> >
> > I want to install without this option.
> >
> > Please let me know what needs to be done to remove
> > this error ?
> I think, at least one of the scripts in your
> test-2.0-B16 package contains line
> #!/sbin/sh
>
> So, or change this script(s) if you can use something
> else, or create another package which will
> provide/install  /sbin/sh and install it before test-2
> rpm.
>
> Valery
>
> >
> > Regs,
> > Manjula
> >
> >
>
> __________________________________________________
> Do you Yahoo!?
> Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
> http://mailplus.yahoo.com
>
> _______________________________________________
> Rpm-list mailing list
> Rpm-list@redhat.com
> https://listman.redhat.com/mailman/listinfo/rpm-list




--- End Message ---

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []