[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: change to epoch



On Tue, Jan 07, 2003 at 01:08:11PM -0800, Jesse Keating wrote:
> On Tue, 7 Jan 2003 16:00:14 -0500
> Jeff Johnson <jbj@redhat.com> wrote:
> 
> > 
> > Fix the packages, I say. Again and again.
> 
> Ok, how does one fix it?  The worry I am seeing, is that if epoch is
> assumed to be 0:, won't we have to specify the epoch version in the
> Requires: section of an rpm spec file?  What about rpms like mozilla,
> that have an epoch of ~35, do we now have to specify this epoch when
> listing mozilla as a Requirement?  How would one "fix" the package?

You put in an explicit epoch, duh. That means instead of writing
	Requires: mozilla = 1.2.1
you write
	Requires: mozilla = 35:1.2.1

The above assumes that you want *exactly* the mozilla-1.2.1 package.

What you probably want is
	Requires: mozilla >= 35:1.2.1
which will continue to match for all future changes to Epoch: (and
version/release) in mozilla.

73 de Jeff

-- 
Jeff Johnson	ARS N3NPQ
jbj@redhat.com (jbj@jbj.org)
Chapel Hill, NC





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []