[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: change to epoch



On Tue, Jan 07, 2003 at 01:17:12PM -0800, Jesse Keating wrote:
> On Tue, 7 Jan 2003 16:13:57 -0500
> Jeff Johnson <jbj@redhat.com> wrote:
> 
> > What you probably want is
> > 	Requires: mozilla >= 35:1.2.1
> > which will continue to match for all future changes to Epoch: (and
> > version/release) in mozilla.
> 
> So I take it all previous rpms that were build have to be rebuild to
> include the epoch?  Previously we would just list mozilla >=1.2.1, but
> now we have to re-do that.  Hrm, this is a huge bummer.

Too bad. rpm has always worked this way, with Epoch: as the most
significant part of comparison. What's different is that you just
noticed.

> 
> But as far as packages w/out epoch in the spec, we can continue to just
> use version number in the Requires: section?  Say, Requires: syslinux >=
> 1.60 ?
> 

Yup.

73 de Jeff

-- 
Jeff Johnson	ARS N3NPQ
jbj@redhat.com (jbj@jbj.org)
Chapel Hill, NC





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []