[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

problem trying to upgrage mozilla and galeon thru rpm



Hi,

I'm having a problem trying to upgrade mozilla and
galeon through rpm. I have Redhat 7.2; 2.4.7-10
kernel. My rpm version is 4.0.2. Any
suggestion/comment will help loads...

I have the following packages currently installed in
my system:

galeon-0.11.3-2;
gdk-pixbuf-0.11.0-8;
gdk-pixbuf-gnome-0.11.0-8;
mozilla-0.9.2.1-2;
mozilla-chat-0.9.2.1-2;
mozilla-mail-0.9.2.1-2;
package mozilla-nspr is not installed;
package mozilla-nss is not installed;
mozilla-psm-0.9.2.1-2;
nautilus-1.0.4-43;
nautilus-mozilla-1.0.4-43

I run up2date (after synching it) and download the
following packages (as instructed by up2date):

galeon-1.2.6-0.7.2.i386.rpm;
mozilla-nspr-1.0.1-2.7.2.i386.rpm;
gdk-pixbuf-0.14.0-0.7.2.i386.rpm;
mozilla-nss-1.0.1-2.7.2.i386.rpm;
gdk-pixbuf-gnome-0.14.0-0.7.2.i386.rpm;
mozilla-psm-1.0.1-2.7.2.i386.rpm;
mozilla-1.0.1-2.7.2.i386.rpm;
nautilus-1.0.4-48.i386.rpm;
mozilla-chat-1.0.1-2.7.2.i386.rpm;
nautilus-mozilla-1.0.4-48.i386.rpm
mozilla-mail-1.0.1-2.7.2.i386.rpm

After that, I go to /var/spool/up2date and check I
only have the downloaded rpms there (and the .hdrs, of
course). Then issue the following commands and receive
the following error messages:

[root] rpm -Uvh mozilla-nspr-1.0.1-2.7.2.i386.rpm 
error: failed dependencies:
mozilla < 0.9.9 conflicts with
mozilla-nspr-1.0.1-2.7.2

[root] rpm -Uvh mozilla-nss-1.0.1-2.7.2.i386.rpm 
error: failed dependencies:
mozilla-nspr = 1.0.1-2.7.2 is needed by
mozilla-nss-1.0.1-2.7.2

[root] rpm -Uvh *.rpm

error: failed dependencies:
mozilla-nspr = 1.0.1-2.7.2 is needed by
mozilla-1.0.1-2.7.2;
libnspr4.so   is needed by mozilla-1.0.1-2.7.2;
libplc4.so   is needed by mozilla-1.0.1-2.7.2;
libplds4.so   is needed by mozilla-1.0.1-2.7.2;
libnspr4.so   is needed by mozilla-mail-1.0.1-2.7.2;
libplc4.so   is needed by mozilla-mail-1.0.1-2.7.2;
libplds4.so   is needed by mozilla-mail-1.0.1-2.7.2;
mozilla-nss = 1.0.1-2.7.2 is needed by
mozilla-psm-1.0.1-2.7.2;
libnspr4.so   is needed by mozilla-psm-1.0.1-2.7.2;
libnss3.so   is needed by mozilla-psm-1.0.1-2.7.2;
libplc4.so   is needed by mozilla-psm-1.0.1-2.7.2;
libplds4.so   is needed by mozilla-psm-1.0.1-2.7.2;
libsmime3.so   is needed by mozilla-psm-1.0.1-2.7.2;
libsoftokn3.so   is needed by mozilla-psm-1.0.1-2.7.2;
libssl3.so   is needed by mozilla-psm-1.0.1-2.7.2;
libnspr4.so   is needed by nautilus-mozilla-1.0.4-48;
libplc4.so   is needed by nautilus-mozilla-1.0.4-48;
libplds4.so   is needed by nautilus-mozilla-1.0.4-48;

I'll greatly appreciate any suggestion or comments on
how to fix this, esp. why is rpm complaining about
dependencies if up2date is supposed to take care of
them? Please note, it only happens with this set of
packages and not with others (ex., glibc suite, kde
etc.) thru up2date and rpm.



__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []