[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Static link question



Sorry; my bad (I think).

in the package rpm-4.1.tar.gz
you'll find:

rpm-4.1/.libs/ .. (bunch of executables)
rpm-4.1/lib/.libs/librpm.a
rpm-4.1/rpmdb/.libs/librpmdb.a
rpm-4.1/rpmio/.libs/librpmio.a


That should fix you up  ;-)


"Adam H. Pendleton" wrote:
> 
> Are you using rpm 4.1 or 4.2?  From what I understand, 4.2 only
> requires linking to librpm, but 4.1 requires linking to more than just
> librpm.  Specifying "-lrpm" still gives me the missing dependencies
> listed in the previous email.
> 
> ahp
> 
>   ------------------------------------------------------------------------
>               Name: PGP.sig
>    PGP.sig    Type: application/pgp-signature
>           Encoding: 7bit





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []