[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Bug #82418



On Wed, Jan 22, 2003 at 05:56:11AM -0500, Adam H. Pendleton wrote:
> You closed bug 82418 by instructing me to "Use -lrpmdb, not 
> -lrpmdb-4.1", which is correct, except that I am *not* linking 
> rpmdb-4.1, I am linking librpm.
> 

You're linking the set of libraries needed to use rpm. That means
that you will need to link
	librpm
	librpmdb
	librpmio
	libpopt
	libbz2
	libz
	libpthread
	librt
in approximately that order.

Don't use libtool or don't statically link are your choices atm.

Try using LDFLAGS, not LDADD.

73 de Jeff

-- 
Jeff Johnson	ARS N3NPQ
jbj@redhat.com (jbj@jbj.org)
Chapel Hill, NC





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []