[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

newbie-packager confusion


I have just tried out to build my first rpm package out of a tarball.
As i wanted to get started with a simple example, I tried it with
castle-combat (rampart-clone for linux) that is compiling fine on my
RedHat 8.0 machine (rpm-version 4.1). 

The "prep" and the "build" stage seem to work (I encountered no errors
using the -bp and -bc command line switches with rpmbuild), but when I
do a "list check" the following error occurs:

Checking for unpackaged file(s): /usr/lib/rpm/check-files %{buildroot}
getOutputFrom(): Datenuebergabe unterbrochen (broken pipe)

I thought that there must be something wrong with the file-list. It's
pretty long, so I put a #before every line and made the "list check"
again and again, removing the #'s one by one. That worked at first
(when using "-ba" the rpm's were generated, too), but when I had about
15 files in the file list, the above error occured.

This problem doesn't seem to dependent on the specific file but just on
the number of files in the file-list.        



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []