[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Is this a bug?



On Sat, Jan 25, 2003 at 09:59:34AM -0500, Ted Kaczmarek wrote:
> [builder@tedkaz builder]$ rpmbuild --rebuild --target=athlon 
> perl-Net-Telnet-3.01-6.src.rpm
> Installing perl-Net-Telnet-3.01-6.src.rpm
> Building target platforms: athlon
> Building for target athlon
> error: Failed build dependencies:
>         perl >= 5.00503 is needed by perl-Net-Telnet-3.01-6

Adding --nodeps to rpmbuild will skip the check.

Otherwise, change the build dependency to have an explicit Epoch:.
Probably
	BuildPreReq: perl >= 0:5.00503
will do the trick. Note that BuildPreReq: and BuildRequires: are synonyms,
there's no difference at all.

> [builder@tedkaz builder]$ rpm -q perl
> perl-5.8.0-55
> [builder@tedkaz builder]$ 
> 
> It appears that this should work?
> This is on RH 8.0 with rpm 4.1-9.
> 
> If it wasn't for rmp2cpio I would have committed suicide a long time ago
> :-)

Me too.

73 de Jeff

-- 
Jeff Johnson	ARS N3NPQ
jbj@redhat.com (jbj@jbj.org)
Chapel Hill, NC





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []