[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

problem with rpm



Hi,

I am running RH 8 on intel platform. I am trying to build an rpm from a
tarball. So far I have created my specs file:

Summary: squid version 2.5 stable release 3. web proxy server
Name: squid
Version: 2.5.STABLE3
Release: 3
License: GPL
Group: Applications/Internet
Source0:/usr/local/src/squid-2.5.STABLE3.tar.gz
Buildroot: %{_tmppath}/%{name}-%{version}-root
Prereq: gcc
%description
The squid package contains the application, conf files etc for the proxy
server squid.
#the prep section
%prep
%setup  -b 0
%build
./configure --prefix="/usr" --sysconfdir="/etc/squid"
--enable-storeio="diskd ufs" --enable-auth="ntlm basic"
--enable-basic-auth-helpers="winbind SMB PAM MSNT"
--enable-ntlm-auth-helpers="fakeauth SMB winbind"
make
%install
make install
%files
%doc ./doc/*
/usr/share/doc/squid-2.5.STABLE3

Once I have been able to make a full rpm with this spec file, but all
the other times it just seems to make a truncted version that will only
install the lib and doc files. No binaries are installed. what have I
done wrong here?

Thanks, gillian




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []