[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Building Custom Kernel RPM from SRPM



Didn't work :-(

Output from build:
-----------------------------------------------------------------------------------------------
/usr/src/redhat/BUILD/kernel-2.4.18/linux
Processing files: kernel-2.4.18-24.8.0_gre_wccp
Provides: module-info kernel = 2.4.18 kernel-drm = 4.1.0 kernel-drm = 4.2.0
PreReq: rpmlib(VersionedDependencies) <= 3.0.3-1 fileutils modutils >= 2.4.18 initscripts >= 5.83 mkinitrd >= 3.2.6 /bin/s
h /bin/sh /bin/sh rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <= 3.0.4-1
Requires(interp): /bin/sh /bin/sh /bin/sh /bin/sh
Requires(rpmlib): rpmlib(VersionedDependencies) <= 3.0.3-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNa
mes) <= 3.0.4-1
Requires(pre): /bin/sh
Requires(post): /bin/sh
Requires(preun): /bin/sh
Requires: /bin/sh
Conflicts: ppp <= 2.3.15 pcmcia-cs <= 3.1.20 isdn4k-utils <= 3.0 mount < 2.10r-5 nfs-utils < 0.3.1 cipe < 1.4.5 tux < 2.1.
0 kudzu <= 0.92 e2fsprogs < 1.22 initscripts < 5.84 dev < 3.2-7 iptables < 1.2.5-3 bcm5820 < 1.81 nvidia-rh72 <= 1.0
Obsoletes: kernel-modules kernel-sparc
Processing files: kernel-source-2.4.18-24.8.0_gre_wccp
Finding  Provides: /usr/lib/rpm/find-provides
Finding  Requires: /usr/lib/rpm/find-requires
PreReq: fileutils /bin/sh /bin/sh rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <= 3.0.4-1
Requires(interp): /bin/sh /bin/sh /bin/sh
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <= 3.0.4-1
Requires(post): /bin/sh
Requires(postun): /bin/sh
Requires: gawk gcc >= 2.96-75 /bin/sh /bin/sh libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.3) lib
m.so.6 libm.so.6(GLIBC_2.0)
Processing files: kernel-doc-2.4.18-24.8.0_gre_wccp
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.91911
Finding  Provides: /usr/lib/rpm/find-provides
Finding  Requires: /usr/lib/rpm/find-requires
PreReq: rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <= 3.0.4-1
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <= 3.0.4-1
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/kernel-2.4.18-24.8.0_gre_wccp-root


RPM build errors:
-------------------------------------------------------------------------------

Axel Thimm wrote:
On Sat, Mar 01, 2003 at 11:28:22AM -0800, Tom Hutchison wrote:
  
I am trying to build a custom Redhat 8.0 Kernel RPM from a custom patched 
kernel-2.4.18-24.8.0.src.rpm.  I have built my patch, modified the 
kernel-2.4.spec file to apply my patch. Put the patch in the 
/usr/src/SOURCES directory and am ready to go.

To build both a binary and source RPM I use:  rpmbuild 
--target=i386-redhat-linux --clean -ba kernel-2.4.spec
    

Try the following:

rpmbuild --target i386 --without smp --without BOOT --without bigmem --without debug -bb kernel-2.4.spec

and search (the bottom of) the output for the String "Wrote:".
  


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []