[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Rawhide Rpm 4.2.0-65 on Redhat 8.0, 4



On Sun, Feb 02, 2003 at 09:58:59AM -0500, Jeff Johnson wrote:
> On Sun, Feb 02, 2003 at 09:14:23AM -0500, Ted Kaczmarek wrote:
> > Has anyone tried rpm 4.2.0-65 on RH 8 yet?

> 2) db-4.1.24 is compiled with --enable-posixmutexes using nptl.
> 
>    [...] rpm checks for the necessary functionality, and sets DB_PRIVATE
>    (i.e. only a single process will access the database) if NPTL is not
>    available.

> So, if you want to try rpm-4.2 from Raw Hide, I'd suggest
> 
> 0) Save a copy of your database
>   	cd /var/lib
> 	tar czvf rpmdb.tar.gz rpm/Packages
> 
> 1) Upgrade to (at least) glibc-2.3.1-38 and kernel-2.4.20-2.26 so that
>    NPTL is functional.
> 
> 2) Upgrade to rpm-4.2-0.65 or later.

Is it possible to skip step 1 (no kernel/glibc upgrade and no nptl)? Would
then 4.2 behave like previous rpms concerning locking?

Thanks.
-- 
Axel.Thimm@physik.fu-berlin.de

Attachment: pgp00001.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []