[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: db4 error in RH8.1 beta-3's rpm



On Wed, 2003-02-26 at 11:47, Jeff Johnson wrote:
> On Wed, Feb 26, 2003 at 10:30:06AM -0600, Paul Johnson wrote:
> > Can you tell me how to fix this? I'm running RedHat 8.1 beta-3 and rpm 
> > version is rpm-4.2-0.66
> > 
> 
> You can't fix.
> 
> > # rpm --rebuilddb
> > error: db4 error(16) from dbenv->remove: Device or resource busy
> > 
> > rpm still seems to work--can remove, add packages.
> > 
> 
> There's nothing really wrong. The dbenv is used by two opens of /var/lib/rpm
> indices, one early to grab public keys, the other later when installing.
> 
> There's an attempt to remove the environment from the 1st instance close,
> fails because the environment is still in use by the second instance,
> harmless but noisy.
> 
> > I think the problem started when I accidentally ran 2 rpm jobs at one 
> > time. One was upgrading scrollkeeper and the other tried to update some 
> > gnome package before the first job was finished (hit return too soon).
> > 
> 
> Possibly. I don't normally (actually hardly ever) see the message, or I
> would have fixed already. There's some other factor which triggers the
> problem, don't know what that is. Doing
> 	rm -f /var/lib/rpm/__db*
> occaisionally might fix.
> 
> The real fix is to stop trying to remove the dbenv entirely, as rpm-4.2
> now always uses a persistent environment.
> 
> 73 de Jeff
Another simillar issue with Phoebe.
Linux nitremb22 2.4.20-2.24 #1 Mon Jan 20 18:30:04 EST 2003 i686 i686
i386 GNU/Linux

rpm -qa as user works fine.

[tazman@nitremb22 tazman]$ rpm -qa | grep glibc
glibc-kernheaders-2.4-8.4
glibc-profile-2.3.1-38
glibc-common-2.3.1-38
glibc-debug-2.3.1-38
glibc-utils-2.3.1-38
glibc-devel-2.3.1-38
glibc-2.3.1-38
[tazman@nitremb22 tazman]$ 

Now as root.

[root@nitremb22 rpm]# su -
[root@nitremb22 root]#  rpm -qa | grep glibc
rpmdb: unable to join the environment
error: db4 error(11) from dbenv->open: Resource temporarily unavailable
error: cannot open Packages index using db3 - Resource temporarily
unavailable (11)
error: cannot open Packages database in /var/lib/rpm
[root@nitremb22 root]# 

This same error is happening with any rpm command as root I have tried.

[tazman@nitremb22 tazman]$ rpm -qa | grep rpm
redhat-rpm-config-8.0.18-1
rpm-build-4.2-0.68
rpm-python-4.2-0.68
rpmdb-redhat-8.0.93-0.20030121
rpm-devel-4.2-0.68
rpm-4.2-0.68

I was really itching to peek at the gtk2 version of Dia too :-(.
-- 
Ted Kaczmarek <tedkaz@optonline.net>

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []