[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Problem upgrading glibc.



[Upgrading things like glibc make me nervous. :-(]

I downloaded all of the new glibc rpms and said:

rpm -Uvh glibc*

It said Preparing 100%
Then is said glibc-common 100%
Then glibc 100%
Then it said restarting init.

Then it just hung.

I killed it with a -9 and tried to see what I had. It said that I could 
not run the rpm -qa command because of a missing libpthread.so

I then ran rpm -Uvh --force glibc* and it ran through the whole thing but 
it still froze on the end of the last package.

Now if I run 

512 > rpm -qa | grep glibc
glibc-utils-2.3.2-4.80
glibc-debug-2.3.2-4.80
glibc-common-2.3.2-4.80
glibc-devel-2.2.93-5
glibc-debug-static-2.3.2-4.80
glibc-kernheaders-2.4-7.20
glibc-2.3.2-4.80
glibc-devel-2.3.2-4.80
glibc-profile-2.3.2-4.80
513 > rpm -qa | grep glibc

It looks like I have two copies of glibc-devel. 

Am I screwed? Can this be fixed? Does it need to be fixed? Is this Red 
Hat's fault? Should people not upgrade to the new glibc? Am I asking too 
many questions?

TIA

-- 
-Time flies like the wind. Fruit flies like a banana. Stranger things have -
-happened but none stranger than this. Does your driver's license say Organ
-Donor?Black holes are where God divided by zero. Listen to me! We are all-
-individuals! What if this weren't a hypothetical question?
steveo at syslang.net






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []