[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

"Requires: kernel = version-release" ignores release?



I observed that requiring a kernel in a package only the version part is
considered.

For example, if I have a specfile with

Requires: kernel = 2.4.18-999

It will gladly accept any 2.4.18 kernel. This is not the case with requiring
other packages, so it looks like this has been done on purpose. Is there a
reason for that?

The application where this becomes important is to package kernel modules
which depend on the explicit kernel.

I have tested it with rpm-4.2-0.70 built on RH 8.0 and rpm-4.1.1-0.1.8x.
-- 
Axel.Thimm@physik.fu-berlin.de

Attachment: pgp00023.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []