[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RPM 4.2 upgrade



Was going to upgrade rpm from 4.1 to 4.2 . I downloaded the following:

popt-1.8-1.i386.rpm
rpm-4.2-1.i386.rpm
rpm-build-4.2-1.i386.rpm
rpm-devel-4.2-1.i386.rpm
Rpm-python-4.2-1.i386.rpm

The install failed .. heres an excerpt of one of the failed packages below. Am I missing any other packages?

       error: Failed dependencies:
       libelf.so.1 is needed by rpm-build-4.2-1
       librpm-4.2.so is needed by rpm-build-4.2-1
       librpmbuild-4.2.so is needed by rpm-build-4.2-1
       librpmdb-4.2.so is needed by rpm-build-4.2-1
       librpmio-4.2.so is needed by rpm-build-4.2-1
       patch >= 2.5 is needed by rpm-build-4.2-1
       rpm = 4.2 is needed by rpm-build-4.2-1

       error: Failed dependencies:
       libc.so.6(GLIBC_2.3.2) is needed by rpm-4.2-1
       libelf.so.1 is needed by rpm-4.2-1
       libelf.so.1(ELFUTILS_1.0) is needed by rpm-4.2-1

This is the glibc installed onmy system ...

glibc-common-2.2.93-5
glibc-2.2.93-5
glibc-kernheaders-2.4-7.20
glibc-devel-2.2.93-5

Thank You.

_________________________________________________________________
Help STOP SPAM with the new MSN 8 and get 2 months FREE* http://join.msn.com/?page=features/junkmail






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []