[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RPM 4.2 upgrade



On Thu, Mar 27, 2003 at 12:51:14PM -0500, M M wrote:
> Was going to upgrade rpm from 4.1 to 4.2 . I downloaded the following:
> 
> popt-1.8-1.i386.rpm
> rpm-4.2-1.i386.rpm
> rpm-build-4.2-1.i386.rpm
> rpm-devel-4.2-1.i386.rpm
> Rpm-python-4.2-1.i386.rpm
> 
> The install failed .. heres an excerpt of one of the failed packages below. 
> Am I missing any other packages?
> 
>         error: Failed dependencies:
>         libelf.so.1 is needed by rpm-build-4.2-1
>         librpm-4.2.so is needed by rpm-build-4.2-1
>         librpmbuild-4.2.so is needed by rpm-build-4.2-1
>         librpmdb-4.2.so is needed by rpm-build-4.2-1
>         librpmio-4.2.so is needed by rpm-build-4.2-1
>         patch >= 2.5 is needed by rpm-build-4.2-1
>         rpm = 4.2 is needed by rpm-build-4.2-1
> 
>         error: Failed dependencies:
>         libc.so.6(GLIBC_2.3.2) is needed by rpm-4.2-1
>         libelf.so.1 is needed by rpm-4.2-1
>         libelf.so.1(ELFUTILS_1.0) is needed by rpm-4.2-1
> 

All the above boils down to
	a) you need glibc-2.3.2 or later.
	b) you need elfutils.

You're better off with rpm-4.1.1 from
	ftp://ftp.rpm.org/pub/rpm/test-4.1.1
which is the same code base, but Berkeley DB is built without
--enable-posixmutexes and elfutils is internal to rpm.

73 de Jeff

-- 
Jeff Johnson	ARS N3NPQ
jbj@redhat.com (jbj@jbj.org)
Chapel Hill, NC





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []