[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpm up2date do not seem to work!



Hi, Leila,

First of all, if you need to start a server, try to do "service httpd start", or use stop (or restart) to stop it (or to stop it and start it again). Running the binary in the terminal is not the right way to start it.

Second, use rpm -q httpd to see whether httpd is already installed. And use rpm -q apache to see whether you still have apache installed.

Third and the most important, it seems that httpd-2.0.40-21.3, specifically the mod_auth_mysql.so, is not happy with your glibc libaries. Are you sure that your glibc libaries are upgraded? I am still not very comfortable with the up2date way to upgrade from 7.2 to 9.0. Why didn't you upgrade 7.2 with the normal installation method?

My suggestion at this stage would be burn the iso's and upgrade it with them. That might come out right if you didn't mess up your system too much with your previous upgrade method.

Good luck. You need it here.


Liguo





Leila Lappin wrote:
Hi Liguo

Thanks for your help.  I did rpm -Uvh and the process
began.  Except that at the end of preparation step I
got the message:

package httpd-2.0.40-21.3 is already installed

The problem is that I cannot start the server which is
whay I thought I needed to upgrade in the first palce.

When I issue, /usr/sbin/httpd

I get an error (shown below). Here's my stupid newbie
question. Why if httpd is installed it is in a state
that does not work? And what do I need to make it
work. I check under /etc/httpd/conf and found
httpd.conf.rpmnew. Do I need to rename that and use
it as the configuration file? Do I need to update
another package to get rid of the error shown below? What package do I need to upgrade? I thank you in
advance for your patience. As I said I am new to
Linux.


Thanks

------  error from httpd command -------
Syntax error on line 6 of
/etc/httpd/conf.d/auth_mysql.conf:
Cannot load /etc/httpd/modules/mod_auth_mysql.so into
server: /usr/lib/libmysqlclient.so.10: symbol errno,
version GLIBC_2.0 not defined in file libc.so.6 with
link time reference





--- Liguo Song <liguo.song@vanderbilt.edu> wrote:

Hi, Leila,


rpm -Fvh httpd-2.0.40-21.3.i386.rpm

This will only install httpd if you already had it installed. And, for RH7.2, it is called apache but not httpd. Try rpm -Uvh. If it doesn't work, try rpm -e apache, then rpm -Uvh httpd-2.0.40-21.3.i386.rpm.


Before, I tried with rpm I tried using up2date,

that


didn't work either I got the following error

message.



-------- error message from up2date

--------------


There was an SSL error: [('SSL routines',
'SSL3_GET_SERVER_CERTIFICATE', 'certificate verify
failed')]



----------------------------------------------------------------

The certificate for up2date expired a while ago. You
might need to
update your up2date first.

Let us know if you still have any problems.

Have a nice day.


Liguo (LeO)



_______________________________________________ Rpm-list mailing list Rpm-list@redhat.com https://www.redhat.com/mailman/listinfo/rpm-list



__________________________________ Do you Yahoo!? The New Yahoo! Shopping - with improved product search http://shopping.yahoo.com


_______________________________________________ Rpm-list mailing list Rpm-list@redhat.com https://www.redhat.com/mailman/listinfo/rpm-list





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]