[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RPM Updating Apache/PHP/MySQL on RH8 or RH9



On Mon, 2003-10-13 at 18:06, Kenneth Porter wrote:
> --On Wednesday, October 08, 2003 1:03 PM -0400 Alan McCoy
> <a.r.mccoy@larc.nasa.gov> wrote:
> 
> > Both RH8 and RH9 offer Apache 2.0.40, PHP 4.2.2, and MySQL 3.23.56 as the
> > highest RPM-based upgrades for Apache/PHP/MySQL.
> > 
> > How can I upgrade to the latest Apache (2.0.47), PHP (4.3.3), and MySQL
> > (4.0.15) using RPMs on either a RH8 or RH9 without having to replace
> > multitudes of dependencies?
> 
> What unresolved dependencies are you encountering? What RPM's are you using?
> Rawhide? Or spec files direct from the upstream sources?
> 
> (I'm about to bring up a RH9 system and will be installing Bugzilla, which
> relies on the same packages, although not necessarily the latest versions, so
> I'd be interested in hearing of any gotchas.)

Here is what I found when trying to upgrade Apache on RH 8.0:

  The Rawhide httpd SRPM is 2.0.47-6.  It has build requirements on
  xmlto (>= 0.0.11), apr-devel (>= 0.9.3-10), apr-util-devel, and
  pcre-devel.

    The latest Rawhide xmlto SRPM is 0.0.15-1.  It has build
    dependencies on docbook-xsl (>= 1.56.0).

      docbook-xsl is provided by docbook-style-xsl.  The latest
      Rawhide version is 1.61.2-2.1;  it builds, but has dependencies
      on docbook-dtd-xml and xml-common (>= 0.6.3-8).

        .....

    The latest Rawhide pcre SRPM is 4.4-1;  it breaks its build (on
    RH 8.0, at least), because it doesn't make a version-qualified
    libpcre.so.0 in $RPM_BUILD_ROOT/usr/lib.

    The latest Rawhide apr SRPM is 0.9.4-2.  It builds cleanly on
    RH 8.0.  apr-utils 0.9.4-2 has it as a build dependency (why aren't
    they in the same SRPM, if they are so tighly coupled?)


This is the sort of mess which I don't want to untangle myself;  I would
vastly prefer to point 'apt-get source httpd' at the appropriate
repository, and have it fetch all the SRPMs I need.

Even there, I am wary of needing to replace this much of the
infrastructure of my system;  I wonder whether all those
version-specific dependencies are actually "hard", or whether the
packager just specified them because it was easier than leaving it open.

Tres.
-- 
===============================================================
Tres Seaver                                tseaver@zope.com
Zope Corporation      "Zope Dealers"       http://www.zope.com




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]