[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

fail to build the binary rpm package for courier IMAP



Hi,

I have installed gcc, db4, rpm by running the following:
#rpm -qa | grep -i gcc
#rpm -qi gcc-2.96-81
#rpm -qa | grep -i db4
#rpm -qi db4-4.0.14-20
#rpm -qa | grep -i rpm
#rpm -qi rpm-4.2-0.69

I was trying create the binary rpm package for courier IMAP by running the
following:

#mkdir $HOME/rpm
#mkdir $HOME/rpm/SOURCES
#mkdir $HOME/rpm/SPECS
#mkdir $HOME/rpm/BUILD
#mkdir $HOME/rpm/SRPMS
#mkdir $HOME/rpm/RPMS
#mkdir $HOME/rpm/RPMS/i386
#echo "%_topdir    $HOME/rpm" >> $HOME/.rpmmacros
#rpm -ta courier-imap-2.1.2.tar.bz2

However, I have been getting this unknown error  "-ta: unknown option"

I have also tried running
#rpmbuild -ta courier-imap-2.1.2.tar.bz2

And I got the following error
error: Failed build dependencies:
        postgresql-devel is needed by courier-imap-2.1.2-1.9
        mysql-devel is needed by courier-imap-2.1.2-1.9
        openldap-servers is needed by courier-imap-2.1.2-1.9


Would anyone please tell me what I need to do to fix this problem.

Thanks in advance,
Peggy






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]