[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Query all dependent packages



On Sun, 22 Feb 2004, Keith G. Robertson-Turner wrote:

> On Sat, 21 Feb 2004 19:42:04 -0500, Steve Feehan wrote:
> 
> > On Sat, Feb 21, 2004 at 07:38:14PM -0500, Sergei Mikhailov wrote:
> 
> >> Is there an rpm command that would list all packages that depend on a
> >> given package? For example, mod_ssl is one of the packages that
> >> requires that httpd is installed. Say, I want all packages that require
> >> httpd.
> 
> > rpm --whatrequires httpd
> 
> Hmm, different version of RPM?
> Mine needs "--redhatrequires" (4.2.1-0.30 FC1)
>
Actually, --redhatrequires does the query against the distro rpmdb that
contains headers of all rpms that could be installed by the distribution
whereas --whatrequires is going against your systems rpmdb (unless of 
course you specify --dbpath).  So if you question was:

	What rpms on my system require X?

Then --whatrequires is the answer.  If your question is:

	What rpms in my distribution require X?

 Then --redhatprovides is your answer (and I think on fedor its 
--fedorarequires).

Cheers...james
> -
> K.
> 
> 
> _______________________________________________
> Rpm-list mailing list
> Rpm-list@redhat.com
> https://www.redhat.com/mailman/listinfo/rpm-list
> 




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]