[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Cannot update popt and rpm* packages - second post




I am unable to update the popt and rpm* packages under "2.4.21-27.0.2.ELsmp #1 SMP x86_64". I am receiving the following message from up2date.


There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
rpm-libs  4.2.3-13                       requires libelf.so.1
rpm-libs  4.2.3-13                       requires libelf.so.1(ELFUTILS_1.0)

I have elfutils installed. It is version 0.94. Apparently there are no additional updates (to 1.0) because when I invoke up2date manually on the elfutils-libelf package, I get this:

---------------------------------------
# up2date elfutils-libelf
Invalid group id server-cfg

Fetching Obsoletes list for channel: rhel-x86_64-ws-3...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------


The following packages you requested are already updated: elfutils-libelf ---------------------------------------

So why does popt and rpm* want libraries that don't exist? And how can I correct this problem ... or can it be corrected?

Shane



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]