[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: libpixman.so.1 is needed by cairo-0.2.0-1.0.rh9.rf



On Fri, 2005-08-19 at 08:28 -0700, Melissa Hao wrote:
> Hi all,
> 
> I'm in the process of installing dependencies for gtkpod.  Currently
> I'm trying to install cairo.  I get this error:
> 
> [root localhost tmp]# rpm -ivh cairo-0.2.0-1.0.rh9.rf.i386.rpm
> warning: cairo-0.2.0-1.0.rh9.rf.i386.rpm: V3 DSA signature: NOKEY, key
> ID 6b8d79e6
> error: Failed dependencies:
>         libpixman.so.1 is needed by cairo-0.2.0-1.0.rh9.rf
> 
> I've compiled and installed libpixman-0.1.6, /usr/local/lib contains
> libpixman.so.1, and LD_LIBRARY_PATH contains /usr/local/lib ...

RPM expects if you are using a package management system then you are
using RPM for everything.

libpixman.so.1 does not exist in the rpmdb, hence rpm can not find it.

I'd assume the repository you got cairo from also provides it's
dependencies - use a depsolver to install them from there.

Your other options are packaging libpixman yourself (I assume the repo
you used had it though), or making a virtual package providing it and
installing that.

Paul


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]