[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RPM dependency issue...



Hello All,

I am fairly new to RPM and I was hoping someone could help me figure out
some dependency issue I seem to be running across with an rpm package I
have built(RHEL-9).  It looks as though my package has an automatic
generated dependencies with libstdc++.so.5
libstdc++.so.5(CXXABI_1.2)
libstdc++.so.5(GLIBCPP_3.2)

Even though I did not manually specify any of these within my spec file.
Are these default dependencies that are included by rpm V 4.2?  It seems
that when I try to install my rpm on a newer release of RH(RHEL-ES-4)
that has a newer version of the shared library (libstdc++.so.6) present
it gags stating the following:

Error: Failed dependencies:
	libstdc++.so.5(CXXABI_1.2) is needed by mypackage
	libstdc++.so.5(GLIBCPP_3.2) is needed by mypackage
Suggested resolutions: compat-libstdc++-33.3.2.3-47.3.i386.rpm


Any insight would be greatly appreciated.

Best Regards,
-Jim 

_______________________________________________
Rpm-list mailing list
Rpm-list redhat com
https://www.redhat.com/mailman/listinfo/rpm-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]