[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Automatic Dependencies not working



Hello all,

I've been having a problem with automatic dependencies and
rpmbuild. I've tried both rpm-4.2 and rpm-4.1. I'm building on an LFS
i686 system (Glibc-2.3.4 / GCC-3.4.3). When building a package rpm
generates the dependencies only from the Requires: and Prereq: tags but
does not generate dependencies for libraries the package is linked
against.

In the spec files, I tried setting:

AutoReq : yes

and again with,

%define _use_internal_dependency_generator 0
%define __find_provides /usr/lib/rpm/find-provides

and again with

%define __find_requires /usr/lib/rpm/find-requires.perl

Running /usr/lib/rpm/find-provides from the command line on an
installed bin reports the right dependencies. But at the end of a build
I get:

[...]
Processing files: zile-2.2.2-1
Finding  Provides: /usr/lib/rpm/find-provides
Finding  Requires: /usr/lib/rpm/find-requires
Requires(interp): /bin/sh /bin/sh
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
Requires(post): /usr/bin/install-info /bin/sh
Requires(preun): /usr/bin/install-info /bin/sh

But missing, other dependencies which, when building the same spec file
on a Debian Sarge, are given as:

Requires : ld-linux.so.2 libc.so.6 libncurses.so.5 libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.3)

I've googled for the past couple of days but can't find anything. Are
there any configuration files that control the auto dependencies
behavior? I've looked at the /usr/bin/rpm/macros but there isn't
anything related to this other than setting __find_provides.

Tarek

-- 
"Anything in parenthesis can (not) be ignored." - Anonymous


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]