[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

SPEC File help, Requires not working as expected



Hello again,

I am working on defining dependencies for an RPM and having trouble getting the Requires portion to work. I have the following line in my SPEC file:

...
%define kernel 2.6.9-55.0.2.EL
...
Requires:	kernel = %{kernel}

When I run rpm -qpR <rpm> on this package, it prints out the dependency like I would expect:

[:user host:] rpm -qpR <package>-0.2-1.i386.rpm
kernel = 2.6.9-55.0.2.EL
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

...but I can then install the package without having the dependency met. Have I mis-used this value or missed something here? My host is running a kernel from an earlier version and does not have this kernel installed, yet I am able to install this package without issues.

I have tried changing the kernel version to 2.8.9 and that works by preventing the package install and enforcing the dependency so it looks like the Requires does not force checking beyond the first few version numbers. I have found nothing in the documentation that would suggest this limitation.

TIA,
--
Joshua M. Miller - RHCE,VCP


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]