[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Building db2 v9.5 rpm from payload files



Hallo.  I've been basing my head on this for over a week now (up until the
last 2 days I kept finding possible fixes) and IBM hasnt been all that
helpful for typical support reasons (why do they care if I can make an RPM?
they provide 2 installers and a manual process! isnt that enough? /end
sarcasm).  Anyways..  let me provide a bit more information.

I was going to try building the rpm in the same manner that we do some
other 3rd party software distributions, which is basically to run the
installer scripts in the %install portion of the script, gather up the
files and move on.  This didn't get me where I needed to be, and about that
time IBM released a new draft of their "DB2 Up and Running on Linux" which
provided very basic information about a new installation method as of
version 9 of DB2, payload files (tarballs).  Basically the procedure is to
pick the payload files you need, extract them all into a specific
directory, and then run this 1 command and viola, you have a working
install to begin setting up.  Sounded simple enough, and doing it manually
works great.  So I implemented this in the spec file, extracting all the
files and such in %install and then running the command in the %post
section (this way any locally specific voodoo can happen).  The
installation all looks great, but when I try to execute one of the commands
that is part of the standard configuration setup (specifically I'm trying
to run`$IBMDIR/instance/dascrt -u dasusr1`) it fails.

So far I've verified all the files permissions and ownerships, everything
matches.  I also have SELinux disabled.  As far as I can tell they are
identical, except the RPM install won't let me run the commands, but the
manual one will.  I have also tried setting the RPM to not run the 1
command so that I do it manually after the files have just been placed on
the system (which should remove and enviromental idfferences cause now it
also gets run directly as root) and it still doesnt work.

My biggest problem is that I just don't know where to go from here, any
insight would be great.

thanks

-greg swift


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]