[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Making a slight modification and replacing an rpm with the same version - is it possible ?



Hello,
I have a feodra 9 linux machine.

I had downloaded net-tools src rpm and I made a very minor change in the source
code.
Now I created a new rpm after applying this change to the newly created rpm.
(using adding the modification to the .bz2, using rpmbuild, etc).


The new rpm I created is net-tools-1.60-87.fc9.x86_64.rpm.
I have also the same version (net-tools-1.60-87.fc9.x86_64.rpm) installed on my
machine.

Is there a way I can replace the new rpm instead the old one?


 rpm -ivh net-tools-1.60-87.fc9.x86_64.rpm
 gives:

Preparing...                ########################################### [100%]
	package net-tools-1.60-87.fc9.x86_64 is already installed
	file /bin/hostname from install of net-tools-1.60-87.fc9.x86_64
conflicts with file from package net-tools-1.60-87.fc9.x86_64
	file /bin/netstat from install of net-tools-1.60-87.fc9.x86_64
conflicts with file from package net-tools-1.60-87.fc9.x86_64
	file /sbin/arp from install of net-tools-1.60-87.fc9.x86_64 conflicts
with file from package net-tools-1.60-87.fc9.x86_64
	file /sbin/ether-wake from install of net-tools-1.60-87.fc9.x86_64
conflicts with file from package net-tools-1.60-87.fc9.x86_64
	file /sbin/ifconfig from install of net-tools-1.60-87.fc9.x86_64
conflicts with file from package net-tools-1.60-87.fc9.x86_64
	file /sbin/ipmaddr from install of net-tools-1.60-87.fc9.x86_64
conflicts with file from package net-tools-1.60-87.fc9.x86_64

And trying to erase the net-tools is impossible because of its dependencies:

 rpm -e net-tools
error: Failed dependencies:
	net-tools is needed by (installed) openvpn-2.1-0.25.rc7.fc9.x86_64
	net-tools is needed by (installed) initscripts-8.76.1-1.x86_64
	
 rpm -e initscripts
error: Failed dependencies:
	initscripts >= 5.20 is needed by (installed) openssh-5.0p1-1.fc9.x86_64
	initscripts >= 8.36 is needed by (installed) httpd-2.2.8-3.x86_64
	initscripts is needed by (installed) vte-0.16.13-1.fc9.x86_64
	initscripts >= 5.86-1 is needed by (installed) kbd-1.12-31.fc9.x86_64
	initscripts >= 6.75 is needed by (installed) dhclient-4.0.0-14.fc9.x86_64
	initscripts >= 8.63-1 is needed by (installed) mkinitrd-6.0.52-2.fc9.x86_64
	initscripts >= 0:5.99 is needed by (installed)
system-config-network-tui-1.5.7-1.fc9.noarch
	initscripts >= 7.22-1 is needed by (installed) rhgb-9.0.0-6.fc9.x86_64
	initscripts >= 6.38 is needed by (installed) quota-3.15-6.fc9.x86_64
	initscripts >= 7.73 is needed by (installed) dhcpv6-client-1.0.14-1.fc9.x86_64
	initscripts is needed by (installed) anacron-2.3-59.fc9.x86_64
	initscripts >= 7.31.11.EL-1 is needed by (installed)
ipsec-tools-0.7-13.fc9.x86_64
	initscripts is needed by (installed) kerneloops-0.10-11.fc9.x86_64
	initscripts is needed by (installed)
system-config-services-0.99.15-1.fc9.noarch
	initscripts is needed by (installed) pcsc-lite-1.4.4-3.fc9.x86_64
	initscripts is needed by (installed) ccid-1.2.1-4.fc9.x86_64
	initscripts is needed by (installed) bluez-utils-3.30-2.fc9.x86_64
	initscripts is needed by (installed) ifd-egate-0.05-20.x86_64
	initscripts >= 8.04-1 is needed by (installed) hal-0.5.11-0.7.rc2.fc9.x86_64
	initscripts is needed by (installed) foomatic-3.0.2-59.fc9.x86_64
	initscripts is needed by (installed) net-snmp-5.4.1-14.fc9.x86_64
	initscripts is needed by (installed) BackupPC-3.1.0-2.fc9.noarch
	/sbin/service is needed by (installed) net-tools-1.60-87.fc9.x86_64
	/sbin/service is needed by (installed) rsyslog-3.14.1-2.fc9.x86_64
	/sbin/service is needed by (installed) iputils-20071127-2.fc9.x86_64
	/sbin/service is needed by (installed) cronie-1.0-5.fc9.x86_64
	/sbin/service is needed by (installed) acpid-1.0.6-7.fc9.x86_64
	/sbin/service is needed by (installed) openvpn-2.1-0.25.rc7.fc9.x86_64
	/sbin/service is needed by (installed) smartmontools-5.38-2.fc9.x86_64
	/sbin/service is needed by (installed) mdadm-2.6.4-4.fc9.x86_64
	/sbin/service is needed by (installed) smolt-1.1.1.1-4.fc9.noarch
	/sbin/service is needed by (installed) irqbalance-0.55-9.fc9.x86_64
	/sbin/service is needed by (installed) rng-utils-2.0-1.15.1.fc9.x86_64
	/sbin/service is needed by (installed) anacron-2.3-59.fc9.x86_64
	/sbin/service is needed by (installed) bittorrent-4.4.0-6.fc9.noarch
	/sbin/service is needed by (installed) fuse-2.7.3-2.fc9.x86_64
	/sbin/service is needed by (installed) samba-winbind-3.2.0-1.pre3.9.fc9.x86_64
	/sbin/service is needed by (installed) samba-common-3.2.0-1.pre3.9.fc9.x86_64
	/sbin/service is needed by (installed) setroubleshoot-server-2.0.6-1.fc9.noarch
	/sbin/service is needed by (installed) bluez-utils-3.30-2.fc9.x86_64
	/sbin/service is needed by (installed) ntp-4.2.4p4-6.fc9.x86_64
	/sbin/service is needed by (installed) samba-3.2.0-1.pre3.9.fc9.x86_64
	/sbin/service is needed by (installed) hplip-2.8.2-2.fc9.x86_64
	/sbin/service is needed by (installed) cups-1.3.7-2.fc9.x86_64	

	and so on.
	
	Any ideas?
	
	Regards,
	IB


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]