[Spacewalk-devel] satellite.certificate. namespace

Justin Sherrill jsherril at redhat.com
Tue Nov 18 21:00:59 EST 2008


Jesus M. Rodriguez wrote:
> I would've voted for satellite.certificate. namespace for this type of
> thing. I'm not a big fan of getObjectAttribute type method names.
>
> So instead of satellite.getCertificateExpirationDate() how about
> satellite.certificate.getExpirationDate()?
>
> http://git.fedorahosted.org/git/?p=spacewalk.git;a=commitdiff;h=98bb228cb5617bce0876796bc6f3f4bad917bc6f
>
> jesus
>
> _______________________________________________
> Spacewalk-devel mailing list
> Spacewalk-devel at redhat.com
> https://www.redhat.co

Would anything else go in 'satellite.certificate'?  Seems kinda silly to
have a namespace just for one call.  The only other thing that I can
think of that would go in that namespace would be entitlement
information, and there are other ways to get that.

-Justin




More information about the Spacewalk-devel mailing list