[Spacewalk-devel] spacewalk-nightly repo with broken dependency on RHEL5/CentOS5

Luc de Louw luc at delouw.ch
Sat Nov 27 09:34:08 EST 2010


Hi all,

I just wanted to install the nightly build from  koji, it failed...

[root at spacewalk-nightly ~]# yum install spacewalk-postgresql
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
  * addons: centos.de-mirror-server.de
  * base: centos.de-mirror-server.de
  * epel: mirrors.se.eu.kernel.org
  * extras: centos.de-mirror-server.de
  * updates: centos.de-mirror-server.de
Setting up Install Process
Resolving Dependencies
--> Running transaction check

[lot of stuff removed]

rhn-client-tools-1.3.1-1.el5.noarch from spacewalk-client has depsolving 
problems
   --> Missing Dependency: python-ethtool >= 0.4 is needed by package 
rhn-client-tools-1.3.1-1.el5.noarch (spacewalk-client)
Error: Missing Dependency: python-ethtool >= 0.4 is needed by package 
rhn-client-tools-1.3.1-1.el5.noarch (spacewalk-client)
  You could try using --skip-broken to work around the problem
  You could try running: package-cleanup --problems
                         package-cleanup --dupes
                         rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
[root at spacewalk-nightly ~]#

On 
http://koji.spacewalkproject.org/spacewalk/split/spacewalk-5E/server/spacewalk-5E-nightly/x86_64/os/ 
only an old 0.3.5 version is available.

Any hints?

Thanks,

Luc




More information about the Spacewalk-devel mailing list