[Spacewalk-devel] [Fwd: Oracle Database 11g Express Edition Beta!]

Jan Pazdziora jpazdziora at redhat.com
Mon Apr 11 08:24:46 EDT 2011


On Sun, Apr 10, 2011 at 10:35:53AM +0200, Luc de Louw wrote:
> 
> I already made tests with 1.4 nightly and XE11 on EL6. I tested some
> very basic stuff like installing, ISS, registering a client. It
> basically works. There are some issues:
> 
> 1. Installation of oracle XE 11 failed:
> 
> Transaction Test Succeeded
> Running Transaction
> Error in PREIN scriptlet in rpm package oracle-xe-11.2.0-0.5.x86_64
> error: "net.bridge.bridge-nf-call-ip6tables" is an unknown key
> error: "net.bridge.bridge-nf-call-iptables" is an unknown key
> error: "net.bridge.bridge-nf-call-arptables" is an unknown key
> error: %pre(oracle-xe-11.2.0-0.5.x86_64) scriptlet failed, exit status 255
> error:   install: %pre scriptlet failed (2), skipping oracle-xe-11.2.0-0.5
> 
> Failed:
>   oracle-xe.x86_64 0:11.2.0-0.5
> 
> However, with rpm -ihv --noscript I was able to install it.

The better approach is not to --noscript but to run the rpm -Uvh
twice, to get sysctl settled:

	https://fedorahosted.org/spacewalk/wiki/OracleXeSetup#OracleXEitself

If you noscript it, you might lose potentially useful changes that
the %pre / %post scriptlets make to the installation.

> 2. Installation of oracle-xe-selinux failes due to dependency
> problems (oracle-xe-univ vs. oracle-xe):
> 
> ---> Package oracle-xe-selinux.noarch 0:10.2.0.20-1.el6 set to be updated
> --> Processing Dependency: oracle-xe-univ for package:
> oracle-xe-selinux-10.2.0.20-1.el6.noarch
> ---> Package setools-libs.x86_64 0:3.3.7-4.el6 set to be updated
> --> Finished Dependency Resolution
> Error: Package: oracle-xe-selinux-10.2.0.20-1.el6.noarch (spacewalk)
>            Requires: oracle-xe-univ
> 
> No problem so far with rpm -ihv --nodeps
> oracle-xe-selinux-10.2.0.20-1.el6.noarch.rpm
> 
> Have not seen any oracle releated AVCs afterwards.

Please check (ps axuZ) what SELinux domain the Oracle processes are in
-- I assume it will not be properly confined as the location of the
binaries changed since oracle-xe-univ, so the file context don't apply
for the version 11. If you or someone want to spend the time updating
the path to match the new version, I'm willing to apply a patch, but
we don't know what Oracle plans to use as the final (non-beta)
location, so it might be just a waste of time if they go back to the
10-ish setup later.

-- 
Jan Pazdziora
Principal Software Engineer, Satellite Engineering, Red Hat




More information about the Spacewalk-devel mailing list