[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Spacewalk-list] problem with scheduled update



Hi,

We were pushing updates this morning through Spacewalk 0.5 and OSAD and
on one of the machines/clients we got an Python error:

[Wed Jun 17 05:05:12 2009] up2date successfully retrieved authentication
token from up2date server
[Wed Jun 17 05:12:07 2009] up2date
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 273, in __run_action
    (status, message, data) = CheckCli.__do_call(method, params)
  File "/usr/sbin/rhn_check", line 266, in __do_call
    retval = method(*params)
  File "/usr/share/rhn/actions/packages.py", line 246, in update
    return runTransaction(transaction_data)
  File "/usr/share/rhn/actions/packages.py", line 279, in runTransaction
    return _run_yum_action(command)
  File "/usr/share/rhn/actions/packages.py", line 301, in _run_yum_action
    yum_base = YumAction()
  File "/usr/share/rhn/actions/packages.py", line 53, in __init__
    self.doTsSetup()
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 86, in
doTsSetup
    return self._getTs()
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 101, in
_getTs
    self._getTsInfo(remove_only)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 112, in
_getTsInfo
    pkgSack = self.pkgSack
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 591, in
<lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 434, in
_getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 251, in
populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 159, in
populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 216, in
_check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 966, in
_check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1124, in
<lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1120, in
_getRepoXML
    raise Errors.RepoError, msg


Do you know how we can fix it?
Reinstall the client tools?

Kind regards,

Michiel


Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]