[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Spacewalk-list] osa-dispatcher not running or not connecting



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



- -------- Original Message --------
Subject: Re: [Spacewalk-list] osa-dispatcher not running or not connecting
From: Joshua Roys <joshua roys gtri gatech edu>
To: Michiel van Es <Michiele info nl>
Date: 10/27/2009 03:06 PM

> On 10/27/2009 09:54 AM, Michiel van Es wrote:
>> File "<string>", line 1, in connect\nerror: (111, \'Connection
>> refused\')\n')
>> File "<string>", line 1, in connect\nerror: (111, \'Connection
>> refused\')\n')
>> osad/jabber_lib.setup_connection('Could not connect to any jabber server',)
> 
> Hello,
> 
> Now that I'm looking a bit closer, you've been getting 2 different errors:
> 
> error: (104, \'Connection reset by peer\')\n
> and
> error: (111, \'Connection refused\')\n
> 
> Right now you're getting connection refused - is port 5222 open and c2s 
> still running?

[root devmx01 ~]# nc -vv devmx01.buro.info.nl 5222
Connection to devmx01.buro.info.nl 5222 port [tcp/xmpp-client] succeeded!

[root devmx01 ~]# ps aux | grep c2s
jabber    3998  0.0  0.1   8928  3912 ?        S    14:52   0:00
/usr/bin/c2s -c /etc/jabberd/c2s.xml -D
root      4916  0.0  0.0   3912   672 pts/1    R+   15:06   0:00 grep c2s

I think it can connect but something else is wrong:

2009/10/27 15:05:53 +02:00 4848 0.0.0.0:
osad/jabber_lib._get_jabber_client('Connecting to', 'devmx01.buro.info.nl')
2009/10/27 15:05:53 +02:00 4848 0.0.0.0: osad/jabber_lib.__init__
2009/10/27 15:05:53 +02:00 4848 0.0.0.0: osad/jabber_lib.__init__
2009/10/27 15:05:53 +02:00 4848 0.0.0.0:
osad/jabber_lib.check_cert('Loading cert', <X509Name object
'/C=NL/ST=Noord Holland/L=Amsterdam/O=Info.nl
HF/OU=devmx01.buro.info.nl/CN=devmx01.buro.info.nl'>)
2009/10/27 15:05:53 +02:00 4848 0.0.0.0: osad/jabber_lib.connect
2009/10/27 15:05:53 +02:00 4848 0.0.0.0:
osad/jabber_lib.connect('Attempting to connect',)
2009/10/27 15:05:56 +02:00 4848 0.0.0.0: osad/jabber_lib.process(300,)
2009/10/27 15:05:56 +02:00 4848 0.0.0.0: osad/jabber_lib.process('before
select(); timeout', 299.99999499320984)


It is seeing the certificate so the port and cert are working but then
something else fails..

The strange thing is that I start osa-dispatcher with -N -vvvvvvv but
then I see not that many logging to the std output or my terminal, just:

[root devmx01 sbin]# ./osa-dispatcher -N -vvvvvvvvvvvv
- --> <?xml version='1.0' encoding='UTF-8'?><stream:stream
to='devmx01.buro.info.nl' xmlns='jabber:client'
xmlns:stream='http://etherx.jabber.org/streams' version='1.0'>



> 
> Josh

Michiel
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkrm/x8ACgkQSU+5fmlaNkO4RwCggtyW9xui5bn9TyVfN6OuLNIT
3c8AoNV/Bgv0qSlaC6QWLa16xGKhz+1S
=4Dbz
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]