[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Spacewalk-list] Problem with taskomatic on new 1.0 install



On 18 May 2010 15:31, Brian T. O'Neill <btoneill walleyesoftware com> wrote:
> I have just installed 1.0, brand new install. There were some issues where
> it appears that the install didn’t complete. After the install was done,
> neither jabber, taskomatic, or osa-dispatcher worked. I was able to get
> jabber and osa-dispatcher working by finishing the proper configs in files
> by hand. I’m still stuck on taskomatic.
>
>
>
> What is happening is taskomatic is going to http://127.0.0.1/rpc/api which
> doesn’t exist (it does exist when using https). So, I have basically
> narrowed the issue down to either one of two problems:
>
> #1 /rpc/api should work on http and my initial setup missed this and I have
> no idea how to get it working properly
>
> Or
>
> #2 Some config file should be telling taskomatic to use https instead of
> http (thinking some file should be pointing at a pem file but isn’t…)
>
>
>
> Anyone happen to have an idea if the fix is #1 or #2 and hopefully how to do
> it?
>
>
>
> Any help would be greatly appreciated.
>
>
>
> Thanks,
>
> Brian
>
> _______________________________________________
> Spacewalk-list mailing list
> Spacewalk-list redhat com
> https://www.redhat.com/mailman/listinfo/spacewalk-list
>

If it was a brand new install with little done to be honest I'd be
inclined to do it again from scratch given it is hard to trace at best
what was left outstanding to do... timewise it might be quicker to do
that than to try and debug issues as a fallout of an incomplete
install in the future...

With regards to your specific query... it sounds like the httpd server
didn't get properly configured as the RPC API is definitely available
over http as well as https in my install... and I believe in my
install (but this is off the top of my head) my taskomatic connects to
my fully qualified hostname rather than 127.0.0.1 so it sounds like
something wasn't quite right there either...

James


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]