[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Spacewalk-list] error during upgrade spacewalk 1.2 to 1.3



On Thu, Feb 17, 2011 at 09:22:35PM +0100, rob morrien wrote:
> 
> during the upgrade from spacewalk 1.2 to 1.3 i got the next error:
> 
> --> Processing Dependency: libyaml-0.so.1 for package: PyYAML
> --> Finished Dependency Resolution
> PyYAML-3.08-4.el5.i386 from installed has depsolving problems
>   --> Missing Dependency: libyaml-0.so.1 is needed by package
> PyYAML-3.08-4.el5.i386 (installed)
> Error: Missing Dependency: libyaml-0.so.1 is needed by package
> PyYAML-3.08-4.el5.i386 (installed)
> 
> how can i fix this problems

On my Spacewalk 1.2:

# rpm -q spacewalk-schema
spacewalk-schema-1.2.69-1.el5
# rpm -q PyYAML
PyYAML-3.08-4.el5
# rpm -q libyaml
libyaml-0.1.2-3.el5
# rpm -ql libyaml
/usr/lib64/libyaml-0.so.1
/usr/lib64/libyaml-0.so.1.1.0
/usr/share/doc/libyaml-0.1.2
/usr/share/doc/libyaml-0.1.2/LICENSE
/usr/share/doc/libyaml-0.1.2/README
# 

On my Spacewalk 1.3:

# rpm -q spacewalk-schema
spacewalk-schema-1.3.18-1.el5
# rpm -q PyYAML
PyYAML-3.08-4.el5
# rpm -q libyaml
libyaml-0.1.2-3.el5
# rpm -ql libyaml
/usr/lib64/libyaml-0.so.1
/usr/lib64/libyaml-0.so.1.1.0
/usr/share/doc/libyaml-0.1.2
/usr/share/doc/libyaml-0.1.2/LICENSE
/usr/share/doc/libyaml-0.1.2/README
# 

So nothing has changed between Spacewalk 1.2 and 1.3.

My assumption is that your 1.2 installation already had the
dependencies broken. In any case, both packages are in EPEL.

-- 
Jan Pazdziora
Principal Software Engineer, Satellite Engineering, Red Hat


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]