[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Spacewalk-list] Problem on first installation



Hi all,
I'm new with Spacewalk.
I'm able to install and make the first configuration on Centos 5.7,
and version Spacewalk 1.6 + Postgress

I follow these guides:
https://fedorahosted.org/spacewalk/wiki/UserDocs#Introduction
http://wiki.centos.org/HowTos/PackageManagement/Spacewalk#head-e04eadc5ed664bd79068564af7d84662c3081b22



Now I'm tring to add channel but I receive always the same error when
try to use

spacewalk-repo-sync

-----------------------------
/usr/bin/spacewalk-repo-sync --channel centos5-updates-i386 \
>                              --url http://mirror.centos.org/centos/5/updates/i386/ \
>
Traceback (most recent call last):
  File "/usr/bin/spacewalk-repo-sync", line 100, in ?
    sys.exit(abs(main() or 0))
  File "/usr/bin/spacewalk-repo-sync", line 93, in main
    sync.sync()
  File "/usr/lib/python2.4/site-packages/spacewalk/satellite_tools/reposync.py",
line 103, in sync
    self.import_packages(plugin, repo_id, url)
  File "/usr/lib/python2.4/site-packages/spacewalk/satellite_tools/reposync.py",
line 309, in import_packages
    packages = plug.list_packages(filters)
  File "/usr/lib/python2.4/site-packages/spacewalk/satellite_tools/repo_plugins/yum_src.py",
line 149, in list_packages
    self.sack.populate(self.repo, 'metadata', None, 0)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 168, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 226, in
_check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1226,
in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1399, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1395,
in _getRepoXML
    raise Errors.RepoError, msg
yum.Errors.RepoError: Cannot retrieve repository metadata (repomd.xml)
for repository: centos5-updates-i386. Please verify its path and try
again
------------------




If I reboot the service I receive:

Starting Monitoring ...
        Starting InstallSoftwareConfig ...  [ OK ]
[ OK ]
Starting MonitoringScout ...
        Starting NPBootstrap ...  2012-01-03 12:33:16 NPBootstrap:
 !! ERROR FROM SHELL COMMAND:
2012-01-03 12:33:16 NPBootstrap:        !! STDOUT: Failed to get scout
shared key data for this node.

2012-01-03 12:33:16 NPBootstrap:        !! STDERR:
2012-01-03 12:33:16 NPBootstrap:        !! EXIT: 256
[ FAIL ]
2012-01-03 12:33:16 NPBootstrap: WARNING: STARTED BUT *NOT* RUNNING
2012-01-03 12:33:16 NPBootstrap: ERRORS ENCOUNTERED DURING LAST ACTION:
2012-01-03 12:33:16 NPBootstrap:        !! ERROR FROM SHELL COMMAND:
2012-01-03 12:33:16 NPBootstrap:        !! STDOUT: Failed to get scout
shared key data for this node.

2012-01-03 12:33:16 NPBootstrap:        !! STDERR:
2012-01-03 12:33:16 NPBootstrap:        !! EXIT: 256
        Starting SputLite ...  [ OK ]
        Starting Dequeuer ...  [ OK ]
        Starting Dispatcher ...  [ OK ]
[ OK ]
--------------------------



what does it means?
what can I do to enable the repository?

THANKS

---
Carlo


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]