[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Spacewalk-list] I can now update CentOS



Daryl,

If you followed the client registration steps I sent before everything should work fine. I've done this on the latest CentOS 6 and 7 and had no problems. Below is a copy of my CentOS 7 steps which are the same for CentOS 6, just changing the urls and file names for CentOS 6. My initial install I had the wrong hostname in my SSL cert due to a typo and had to rebuild it all as the rename didn't work, but from then on I haven't had any problems. I had similar problems with the SSL cert on the first server, some things worked and other didn't. If I remember my clients would register, but then things broke down quickly after that.

 

sudo rpm -Uvh http://spacewalk.redhat.com/yum/2.2-client/RHEL/7/x86_64/spacewalk-client-repo-2.2-1.el7.noarch.rpm

 

sudo rpm -Uvh http://mirror.cogentco.com/pub/linux/epel/7/x86_64/e/epel-release-7-2.noarch.rpm

 

sudo rpm -Uvh http://spacewalk.internal/pub/rhn-org-trusted-ssl-cert-1.0-1.noarch.rpm  (Your server in the url here for SSL cert)


sudo yum install spacewalk-client-setup rhncfg-actions osad rhn-setup fence-agents-all

 

sudo /usr/sbin/rhnreg_ks --serverUrl=http://spacewalk.interal/XMLRPC --activationkey=YOURACTIVATIONKEY

 

sudo rhn-actions-control --enable-run (Enables push)





Ethan Bonick | Information Technology
TruQua

CONFIDENTIAL:  This e-mail and any attachments are confidential and may be protected by legal privilege. If you are not the intended recipient, be aware that any disclosure, copying, distribution or use of this e-mail or any attachment is prohibited. If you have received this e-mail in error, please reply and notify the sender and delete this copy from your system.



On Fri, Nov 14, 2014 at 8:44 AM, Stephen Herr <sherr redhat com> wrote:
Doc updated to include getting the CA cert / using ssl by default.

-Stephen

On 11/12/2014 02:40 PM, Amedeo Salvati wrote:
yes, there are a partial lack on documentations, partial, because if can
see when launch rhnreg_ks on serverUrl it use http and not https, and if
you don't import ca key (by text file or rpm) http will works fine (but
I'm not sure if osad will works), on the other hand https wont works
without ca key



Il 12/11/2014 20:07, Coffman, Anthony J ha scritto:

Good point – I think this step belongs on the
https://fedorahosted.org/spacewalk/wiki/RegisteringClients page.

I’m pretty sure I had the same problem when I originally installed
Spacewalk 0.7 but thought it was just my mistake.

Regards,

--Tony

*From:*spacewalk-list-bounces@redhat.com
[mailto:spacewalk-list-bounces redhat com] *On Behalf Of *Daryl Rose
*Sent:* Wednesday, November 12, 2014 12:14 PM
*To:* spacewalk-list redhat com
*Subject:* Re: [Spacewalk-list] I can now update CentOS

Amedeo,

This is not any any documentation that I can find. As a matter of
fact, when I first started working on this, I ran into an error
about RHN-ORG-TRUSTED-SSL-CERT.  I posted a question to this list, and
a person replied back telling me that I needed to
scp RHN-ORG-TRUSTED-SSL-CERT from the SW server to the client.  That
resolved that particular error, but no where have I found that I need
to install an additional rpm.

I will install it and test.

Thank you.

Daryl

On Wed, Nov 12, 2014 at 9:58 AM, Amedeo Salvati <amedeo oscert net
<mailto:amedeo oscert net>> wrote:

    Daryl this seem that you haven't imported your spacewalk ssl keys,
    usually under pub directory of your SW server you can find two files:

    RHN-ORG-TRUSTED-SSL-CERT
    rhn-org-trusted-ssl-cert-1.0-1.noarch.rpm

    install rpm on your spacewalk clients, and then your clients has
    this ssl key under:

    /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT

    and with this you can use https communications between spacewalk
    server and clients... -> with this is more safe if you have
    provision entitlements and want to execute on real time scripts
    (communication goes through http over ssl)

    Best Regards
    Amedeo Salvati

    Da: spacewalk-list-bounces redhat com
    <mailto:spacewalk-list-bounces redhat com>

    A: Spacewalk-list redhat com <mailto:Spacewalk-list redhat com>

    Cc:

    Data: Wed, 12 Nov 2014 09:33:43 -0600

    Oggetto: [Spacewalk-list] I can now update CentOS

    > Previous questions were about the failure of updating CentOS
    from the Spacewalk server.  I was getting the following error:

    > local action status: ((6,), 'Fatal error in Python code
    occurred', {})

    > I searched and searched and searched, posted questions and no
    one was able to answer the question on what the error was, and how
    to resolve it.

    > The only reply that I received on this board was that this was a
    bug that had been fixed in RH Satellite Server, but apparently not
    in Spacewalk.

    > Perhaps this is a known bug that was only fixed in RH Satellite
    and not addressed in SW because I found other postings with the
    exact same issue.  These postings go back for over a year, so I
    know this has been an issue for sometime.  Almost all of these
    posts have the same replies: execute a yum clean all, update yum,
    etc...  I did all of that as well as did the others in who have
    the same issue. Stop/start the satellite server etc....

    > Finally, I found a posting by a guy who jumped through all of
    the hoops, as had I, but finally found out that removing the "s"
    from the https://<sp-walk <https://%3csp-walk> server> in
    /usr/sysconfig/rhn/up2date resolved the issue.

    > I successfully updated my CentOS 6.5 server.

    > Thank you

    > Daryl


    _______________________________________________
    Spacewalk-list mailing list
    Spacewalk-list redhat com <mailto:Spacewalk-list redhat com>
    https://www.redhat.com/mailman/listinfo/spacewalk-list



_______________________________________________
Spacewalk-list mailing list
Spacewalk-list redhat com
https://www.redhat.com/mailman/listinfo/spacewalk-list



_______________________________________________
Spacewalk-list mailing list
Spacewalk-list redhat com
https://www.redhat.com/mailman/listinfo/spacewalk-list


_______________________________________________
Spacewalk-list mailing list
Spacewalk-list redhat com
https://www.redhat.com/mailman/listinfo/spacewalk-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]