[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Spacewalk-list] System_applyerrata Non-Interactive



Running Spacewalk 2.6, fresh install. When I try to run "system_applyerrata" in a cron job or just at the Bash CLI from an SSH session (as a user who has the necessary permissions to patch systems) nothing happens. As the same user, if I run the command interactively from a spacecmd prompt, it works as expected. I've tried targeting a single client or a group, with the same results. Is there a syntax element I'm missing?

Here's the command I'm using in cron or bash prompt:
spacecmd -y -- system_applyerrata -s now group:PT0 *

--
James Dodd
Jo-Ann Stores, LLC
Senior Technical Engineer, Server & Storage
5555 Darrow Road
Hudson, OH 44236
330.463.3481

CONFIDENTIALITY/EMAIL NOTICE: The material in this transmission contains
confidential and privileged information intended only for the addressee.
If you are not the intended recipient, please be advised that you have
received this material in error and that any forwarding, copying, printing,
distribution, use or disclosure of the material is strictly prohibited.
If you have received this material in error, please (i) do not read it,
(ii) reply to the sender that you received the message in error, and
(iii) erase or destroy the material. Emails are not secure and can be
intercepted, amended, lost or destroyed, or contain viruses. You are deemed
to have accepted these risks if you communicate with us by email. Thank you.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]