[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Loading / accessing tux userspace modules



Hi Marcus,

Yes, the permissions work now, and yes I've got the same behaviour (actually 
I'm not running Apache so I just get a permission denied error again). I've 
been trying to track it down but just changing it to the same style as 
CAD_u.c doesn't seem to have helped (a question here: Is CAD_u.c supposed to 
be compiled into a userspace module in the same way as demo.c? I'm asking 
because it seems to duplicate some of the event handling code from tux.c).

Has anybody actually got a simple _working_ user space module for tux? I'd 
use the CAD_u.c one but it is a bit complex for a simple example / template 
module and has too many external dependencies.

Has anybody worked out how to unload modules? It is very inconvenient having 
to restart the machine each time. (Or is there some other way to reinitialise 
tux, since just restarting the userspace tux daemon doesn't achieve this?)

I tried adding the module unregistering code to stoptux.c, but this fails, I 
think there might be a bug in unregister_httpmodule in httpmod.c:

???????? tmp = lookup_module(tcapi->vfs_name);
???????? if (!tcapi) { ?
???????? ??????? Dprintk("huh, module %s not registered??\n", 
tcapi->vfs_name);
???????? ??????? err = -1;
???????? } else {

I think this should say if(!tmp) instead? The code as it stands doesn't seem 
to make much sense.

Regards,
Janek





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []