[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Loading / accessing tux userspace modules



Janek Mann wrote:
> 
> Hi Marcus,
> 
> Yes, the permissions work now, and yes I've got the same behaviour (actually
> I'm not running Apache so I just get a permission denied error again). I've
> been trying to track it down but just changing it to the same style as
> CAD_u.c doesn't seem to have helped (a question here: Is CAD_u.c supposed to
> be compiled into a userspace module in the same way as demo.c? I'm asking
> because it seems to duplicate some of the event handling code from tux.c).

Yes, as far as I know CAD_u.c is a regular user space TUX module. I did
a little investigation in the demo.so problem and found out that if TUX
gets the request a second time, it thinks it is a cache miss, doesn't
find the module code and redirects the request.

[...]
> 
> Has anybody worked out how to unload modules? It is very inconvenient having
> to restart the machine each time. (Or is there some other way to reinitialise
> tux, since just restarting the userspace tux daemon doesn't achieve this?)
> 
> I tried adding the module unregistering code to stoptux.c, but this fails, I
> think there might be a bug in unregister_httpmodule in httpmod.c:

This is not yet implementet in the TUX kernel code. If you want to have
a look, look at the file net/http/httpmain.c in function
user_unregister_module(). Maybe you implement it yourself. But Ingo
Molnar told me that there will be a TUX 1.01 version soon (whatever
"soon" is ;-) which will fix a lot of problems.

Bye, Marcus


-- 

[ Marcus Gruendler | M.Gruendler@aixigo.de | http://www.aixigo.com ]
[          aixigo AG - Financial Research and Education            ]
[          Schloß-Rahe-Straße 15, 52072 Aachen, Germany            ]





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []