[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[vfio-users] QEMU_ALSA _*values



Hi!

My sound is basically unenjoyable, the trial-and-error method is very slow in this case and I don't have another week for this like last time a couple years back. (using the HDMI audio is not an option)
So I thought I'd ask the list if anyone has some tried and true tips about this.

What I'm rockin:
Gigabyte GA 970-UD3
AMD FX 8120
GeForce GT640 + GTX650

00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)

Some things I tried:
#export QEMU_ALSA_DAC_BUFFER_SIZE=512
#export QEMU_ALSA_DAC_PERIOD_SIZE=170
#export QEMU_ALSA_ADC_PERIOD_SIZE=128
#export QEMU_ALSA_ADC_BUFFER_SIZE=2048

export QEMU_AUDIO_DRV=alsa

#export QEMU_AUDIO_TIMER_PERIOD=100
export QEMU_AUDIO_DAC_FIXED_SETTINGS=1
#export QEMU_AUDIO_DAC_FIXED_FMT=S16
#export QEMU_AUDIO_DAC_FIXED_CHANNELS=2
#export QEMU_AUDIO_DAC_VOICES=1
#export QEMU_AUDIO_DAC_TRY_POLL=0
export QEMU_AUDIO_ADC_FIXED_SETTINGS=1
#export QEMU_AUDIO_ADC_FIXED_FMT=S16
#export QEMU_AUDIO_ADC_FIXED_CHANNELS=1
#export QEMU_AUDIO_ADC_VOICES=1
#export QEMU_AUDIO_ADC_TRY_POLL=0
export QEMU_ALSA_DAC_PERIOD_SIZE=1024
export QEMU_ALSA_DAC_BUFFER_SIZE=512

export QEMU_AUDIO_TIMER_PERIOD=0
export QEMU_AUDIO_DAC_FIXED_FREQ=48000
export QEMU_AUDIO_ADC_FIXED_FREQ=48000
export QEMU_ALSA_DAC_BUFFER_SIZE=16384


Thanks in advance,
aldum

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]