[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [vfio-users] nVidia Code 43



Hey Philip,

Yeah my 2 halfs of the card each have their own IOMMU groups:

/sys/kernel/iommu_groups/33/devices
/sys/kernel/iommu_groups/33/devices/0000:06:00.0
/sys/kernel/iommu_groups/33/devices/0000:06:00.1
/sys/kernel/iommu_groups/34
/sys/kernel/iommu_groups/34/devices
/sys/kernel/iommu_groups/34/devices/0000:07:00.0
/sys/kernel/iommu_groups/34/devices/0000:07:00.1

However if you are struggling to get a 660 working I am worried about my chances with my weirder dual GPU card. Have you tried both Tianocore and Seabios or just Tianocore as could be that your 660 is not compatible with UEFI booting (I had to reflash my 690's with the firmware of another manufacturer's 690 just to obtain that ability). 

I just finished some testing with remapping to different PCI slots inside the VM. Turns out that I cannot fully recreate the mappings the physical machine has inside the virtual machine as there is a restriction on the slot you can assign that states that it has to be >= 1 whereas on my physical machine they are in slot 0 so rather than being:

0000:06:00.0
0000:06:00.1
0000:07:00.0
0000:07:00.1

the closest I can make it is:

0000:06:01.0
0000:06:01.1
0000:07:01.0
0000:07:01.1

Not sure if this is what could be upsetting it or not but it is annoying that I cannot replicate the real world inside the VM. That being said the Arch VM I setup was able to run Unigine Heaven fine on the 690 but it doesn't seem to want to enable MultiGPU mode meaning it only uses one of the 2 GPU's resulting in less than 50% of the performance of running it on the host OS.

Copying those mappings over to the Windows VM resulted in Windows stating initially that the cards were working fine but needed to reinstall their drivers. After the reinstall though I ended up with the same Code 43 error.

Would anyone mind sharing a working nVidia based XML?

Thanks,

Alan Jenkins

On Fri, 11 Dec 2015 at 16:30 Philip Abernethy <chais z3r0 gmail com> wrote:

On Fri, 11 Dec 2015 13:26 Alan Jenkins <alan james jenkins gmail com> wrote:

Has anyone else had success with one?

Sadly all I can say currently is, that I have the exact same problem with my GTX 660. Despite everything I've tried and what was suggested by the people here, I can't get that thing to work, while older and newer cards work just fine.

The only thing I haven't tried yet is using a different slot for the card. Does your card have a IOMMU group on its own? Because mine shares one with the PCI controller.

Philip Abernethy


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]