[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [vfio-users] aacraid / Adaptec 3805 - AAC: Host adapter dead -1



> On Mon, Aug 01, 2016 at 11:42:24AM +0200, Piotr Szymaniak wrote:
> > Hi,
> 
> (Sorry, for almost-topposting. Leaving below for reference.)
> 
> As a followup to this thread - looking for answers here and there I've added
> intel_iommu=igfx_off (found at some thread with some other hardware
> mentioning Sandy Bridge) and it seems to work - just transfered
> 300 gigabytes of data to a testing array. On the other hand it still fills logs with
> those over and over every 10 seconds:
> AAC: Host adapter dead -1
> 
> I'm using Intel i5-2400 with Intel DQ67SW motherboard.
> 
> I've also tried various Live Linux 64-bit distros:
> 1/2. Arch Bang (4.6.4-1-ARCH) and Ubuntu 16.04.1 (4.4.0-31-generic
> #50-Ubuntu) - prints errors every 10 seconds (afair didnt test if it works as I
> expected it doesnt) 3. Ubuntu 14.04 (4.4.0-15-generic #31-Ubuntu) - doesnt
> print errors, works
> 

Hi Piotr,

You had indicated that a kernel using Alex Williamson's patch allowed you to use the system correctly. Is that true?
You also indicated that Ubuntu 14.04 worked, while 16.04 did not. Is that true?

Looking at the aacraid driver shipped with the Ubuntu flavors seems to be the same version of the driver. Do either of those kernel's have Alex's patch applied for the 3805?

At this point, assuming the above statements are true, I would believe that you would get the best results when using a kernel with Alex's
patches applied.

Thanks, -Dave

> Further help appreciated.
> 
> linux-scsi v k o please CC me as I'm not subscribed, thanks.
> 
> 
> Best regards,
> Piotr Szymaniak.
> 
> 
> 
> > I have some issues with Adaptec 3805 and found that it could be
> > related to iommu as described here [1]. I've tried various (iommu=pt
> > etc.) but nothing seems to change the behaviour of the controller.
> > Also tried the patch [2] from Alex Williamson on top of 4.6.5.
> > Controller seems to work fine (random r/w) for some hours under Windows 7
> or (on the same machine) with Clonezilla.
> >
> > Every 10 seconds my dmesg fills with:
> > AAC: Host adapter dead -1
> >
> > Not sure about the state now (as I tried rebuilding kernel with some
> > more PCI related options, various iommu lines in grub etc), but I
> > could read the array (dd if=controller of=/dev/null), but not write.
> > With dd write, trying to make fs or partition or whatever it ended with
> messages similar to this:
> > DMAR: DRHD: handling fault status reg 3
> > DMAR: DMAR:[DMA Write] Request device [03:01.0] fault addr ffbb5000
> > DMAR:[fault reason 02] Present bit in context entry is clear



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]