[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [vfio-users] VFIO hard instant host reboot after VM start with Qualcomm Atheros AR9580



On Tue, 9 Aug 2016 01:43:45 +0200
Maik Broemme <mbroemme libmpq org> wrote:

> Hi,
> 
> whenever I try to start a KVM VM with 'Qualcomm Atheros AR9580 Wireless
> Network Adapter' assigned it will immediately reboot the host. I've tried
> already a couple of things:
> 
> 1. Played with module parameters.
> 
>    vfio_pci nointxmask=1
>    vfio_iommu_type1vfio_iommu_type1 disable_hugepages=1
> 
> 2. Tried kernel 4.4, 4.6 and 4.8rc1.r2.g574673c2
> 
> 3. Tried all different PCIe slots in the system. It is a dual socket
>    system with 6 PCIe slots, where 3 are connected to CPU1 and 3 to
>    CPU2.
> 
> I don't have any clue what the root cause could be. I have tried another
> Wireless card which works fine with VFIO passthrough. It was some old
> D-Link PCIe model but with different chipset.
> 
> Any help would be much appreciated to narrow down the problem.

Probably needs to be added to the broken bus reset list with the other
Atheros devices, see:

http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=c3e59ee4e76686b0c84ca8faa1011d10cd4ca1b8

http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9ac0108c2bac3f1d0255f64fb89fc27e71131b24


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]