[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [vfio-users] vgaarb setting as boot device



Sorry, here is the output of /proc/iomem. 

http://pastebin.com/raw/Gc8QcrJx

On Fri, Aug 19, 2016 at 3:52 PM Cale Rogers <cale rogers m gmail com> wrote:
Hi All,

I seem to be running into a strange issue I can't find a fix for. My rig is:
Gigabyte x99p
Intel i7 5930
4x GTX 1080

The main issue is that I can't passthrough all 4 of my video cards. The last one in use will be chosen as "boot device" by vgaarb according to dmesg. I have tested this by removing one card and it set the PCI boot device as the next one in line and I was then unable to pass that one through. Is there a way to prevent vgaarb from setting a boot device at all? I really don't need a primary graphics card as I am just using ssh to get into the server.

dmesg | grep vgaarb
[ 8.402525] vgaarb: device added: PCI:0000:4b:00.0,decodes=io+mem,owns=none,locks=none
[ 8.402527] vgaarb: device added: PCI:0000:4c:00.0,decodes=io+mem,owns=none,locks=none
[ 8.402529] vgaarb: device added: PCI:0000:4d:00.0,decodes=io+mem,owns=none,locks=none
[ 8.402532] vgaarb: setting as boot device: PCI:0000:4e:00.0
[ 8.402532] vgaarb: device added: PCI:0000:4e:00.0,decodes=io+mem,owns=io+mem,locks=none
[ 8.402533] vgaarb: loaded
[ 8.402534] vgaarb: bridge control possible 0000:4e:00.0
[ 8.402534] vgaarb: bridge control possible 0000:4d:00.0
[ 8.402535] vgaarb: bridge control possible 0000:4c:00.0
[ 8.402536] vgaarb: bridge control possible 0000:4b:00.0





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]