[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [vfio-users] After update, input-linux errors with Operation not permitted.



Strange. I'm user user and group of qemu and 2.0 works for me. I know you need to remove devices from the cgroup line. I did try adding it back for 2.1 but that didn't work. So user as root or qemu doesn't work for me in 2.1.


On 20 Aug 2016 18:04, "sL1pKn07 SpinFlo" <sl1pkn07 gmail com> wrote:
2016-08-20 18:03 GMT+02:00 Jonathan Scruggs <j scruggs gmail com>:
> Caps is a default useflag, so it will set user and group to qemu. So, you
> are saying that the user and group need to be set to root for it to work
> with version 2.1? Version 2.0, which I have now, works fine with qemu as the
> user/group. What has changed to cause this?
>
> On 20 August 2016 at 14:45, sL1pKn07 SpinFlo <sl1pkn07 gmail com> wrote:
>>
>> 2016-08-20 15:34 GMT+02:00 Jonathan Scruggs <j scruggs gmail com>:
>> > This is my whole qemu.conf:
>> > http://dpaste.com/243C3GG
>> >
>> > It's largely default.
>> >
>> > On 20 August 2016 at 14:04, sL1pKn07 SpinFlo <sl1pkn07 gmail com> wrote:
>> >>
>> >> one question, have you configure the user in the qemu.conf? for me in
>> >> older version if have unset that option i have the same fail, but if
>> >> set to 'root' user, work OK. but in libvirt 2.2, unset or set the user
>> >> don't work
>> >>
>> >> greetings
>> >
>> >
>>
>> ok, is commented, but in the ebuild have set to root
>>
>>
>> https://gitweb.gentoo.org/repo/gentoo.git/tree/app-emulation/libvirt/libvirt-2.1.0-r1.ebuild#n295
>>
>> then in my setup need set to root in qemu.config
>>
>> if not:
>>
>> ago 20 14:50:21 sL1pKn07 libvirtd[27566]: libvirt version: 2.2.0
>> ago 20 14:50:21 sL1pKn07 libvirtd[27566]: hostname: sL1pKn07
>> ago 20 14:50:21 sL1pKn07 libvirtd[27566]: Domain id=1 name='windoze'
>> uuid=167cfa49-c88f-46df-a6bf-3127d5bf4d38 is tainted: custom-argv
>> ago 20 14:50:21 sL1pKn07 libvirtd[27566]: Domain id=1 name='windoze'
>> uuid=167cfa49-c88f-46df-a6bf-3127d5bf4d38 is tainted: host-cpu
>> ago 20 14:50:21 sL1pKn07 libvirtd[27566]: Falló al conectar con el
>> socket de monitor: No existe el proceso
>> ago 20 14:50:21 sL1pKn07 libvirtd[27566]: internal error: process
>> exited while connecting to monitor: 2016-08-20T12:50:21.564501Z
>> qemu-system-x86_64: -object
>>
>> input-linux,id=keyboard,evdev=/dev/input/by-path/pci-0000:00:1a.1-usb-0:1.1:1.0-event-kbd,grab_all=on,repeat=on:
>> Could not open
>> '/dev/input/by-path/pci-0000:00:1a.1-usb-0:1.1:1.0-event-kbd
>>
>> └───╼  ls /dev/input/by-path/pci-0000:00:1a.1-usb-0:1.1:1.0-event-kbd
>> lrwxrwxrwx 1 root root 9 ago 19 21:00
>> /dev/input/by-path/pci-0000:00:1a.1-usb-0:1.1:1.0-event-kbd ->
>> ../event0
>
>


Hi

no, i mean, in 2.0 (or older), i need set the user option in root
(user = "root"). if not i get error

exited while connecting to monitor: 2016-08-20T12:50:21.564501Z
qemu-system-x86_64: -object
input-linux,id=keyboard,evdev=/dev/input/by-path/pci-0000:00:1a.1-usb-0:1.1:1.0-event-kbd,grab_all=on,repeat=on:
Could not open '/dev/input/by-path/pci-0000:00:1a.1-usb-0:1.1:1.0-event-kbd

in  2.1 or 2.2, ir set or not the user option i get the error like you

greetings

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]