[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [vfio-users] vfio fails Guest FreeBSD9.3 host Fedora 23



hugepages doesn't work with VFIO it works with vhost.

flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms xsaveopt

On Tue, May 31, 2016 at 7:57 PM, Nicolas Roy-Renaud <nicolas roy-renaud 1 ens etsmtl ca> wrote:

Does your CPU even support those?

https://wiki.debian.org/Hugepages#x86_64


On 2016-05-31 12:26, chintu hetam wrote:
Strange for me both 2MB and 1GB hugepages are failing
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin QEMU_AUDIO_DRV=spice /usr/bin/qemu-kvm -name generic -S -machine pc-i440fx-2.4,accel=kvm,usb=off,vmport=off,mem-merge=off -cpu SandyBridge -m 32768 -mem-prealloc -mem-path /dev/hugepages/libvirt/qemu -realtime mlock=on -smp 8,sockets=8,cores=1,threads=1 -uuid d8f61bc1-dd9a-470f-a26f-824e5e2b8359 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/generic.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc,driftfix=slew -global kvm-pit.lost_tick_policy=discard -no-hpet -no-shutdown -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -boot order=c,menu=on,strict=on -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x6.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x6 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x6.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x6.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 -drive file=/home/vcr/Appliance-4.6.0.0_5-vtnet0.img,if=none,id=drive-virtio-disk0,format=raw -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x8,drive=drive-virtio-disk0,id=virtio-disk0 -drive file=/dev/disk/by-id/scsi-36001405fdc0e99da3aa4b37b1403085c,if=none,id=drive-virtio-disk1,format=raw -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0xa,drive=drive-virtio-disk1,id=virtio-disk1 -netdev tap,fd=23,id=hostnet0,vhost=on,vhostfd=24 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:30:a0:c0,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -spice port=5900,addr=127.0.0.1,disable-ticketing,image-compression=off,seamless-migration=on -device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vgamem_mb=16,bus=pci.0,addr=0x2 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -chardev spicevmc,id=charredir0,name=usbredir -device usb-redir,chardev=charredir0,id=redir0 -chardev spicevmc,id=charredir1,name=usbredir -device usb-redir,chardev=charredir1,id=redir1 -device vfio-pci,host=aa:02.0,id=hostdev0,bus=pci.0,addr=0x9,rombar=0 -device vfio-pci,host=aa:02.1,id=hostdev1,bus=pci.0,addr=0xc,rombar=0 -device vfio-pci,host=aa:02.2,id=hostdev2,bus=pci.0,addr=0xd,rombar=0 -device vfio-pci,host=aa:02.3,id=hostdev3,bus=pci.0,addr=0xe,rombar=0 -device vfio-pci,host=aa:06.0,id=hostdev4,bus=pci.0,addr=0xb,rombar=0 -device vfio-pci,host=aa:06.1,id=hostdev5,bus=pci.0,addr=0xf,rombar=0 -device vfio-pci,host=aa:06.2,id=hostdev6,bus=pci.0,addr=0x10,rombar=0 -device vfio-pci,host=aa:06.3,id=hostdev7,bus=pci.0,addr=0x11,rombar=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7 -msg timestamp=on
char device redirected to /dev/pts/2 (label charserial0)

(process:70685): GLib-ERROR **: gmem.c:100: failed to allocate 1048576 bytes
2016-05-31 16:20:39.371+0000: shutting down
:q

^C
[root localhost vcr]# cat /proc/meminfo
MemTotal:       396231416 kB
MemFree:        318394500 kB
MemAvailable:   318898920 kB
Buffers:            3456 kB
Cached:           595536 kB
SwapCached:            0 kB
Active:           272052 kB
Inactive:         405868 kB
Active(anon):      86760 kB
Inactive(anon):      224 kB
Active(file):     185292 kB
Inactive(file):   405644 kB
Unevictable:       16372 kB
Mlocked:           16372 kB
SwapTotal:       4194300 kB
SwapFree:        4194300 kB
Dirty:                 0 kB
Writeback:             0 kB
AnonPages:         95336 kB
Mapped:           139740 kB
Shmem:              1688 kB
Slab:             292452 kB
SReclaimable:     154600 kB
SUnreclaim:       137852 kB
KernelStack:       12816 kB
PageTables:         9432 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:    164561272 kB
Committed_AS:     725316 kB
VmallocTotal:   34359738367 kB
VmallocUsed:           0 kB
VmallocChunk:          0 kB
HardwareCorrupted:     0 kB
AnonHugePages:         0 kB
CmaTotal:              0 kB
CmaFree:               0 kB
HugePages_Total:   32768
HugePages_Free:    32768
HugePages_Rsvd:        0
HugePages_Surp:        0
Hugepagesize:       2048 kB
DirectMap4k:      227008 kB
DirectMap2M:     4935680 kB
DirectMap1G:    399507456 kB

i tried qemu from preview 1G is failing in that too..dint try 2MB as yet..



On Fri, May 27, 2016 at 3:11 PM, Alex Williamson <alex williamson redhat com> wrote:
[re-adding vfio-users]

On Fri, 27 May 2016 15:03:17 -0400
chintu hetam <rometoroam gmail com> wrote:

> that worked Alex, sorry for the delay in response.
> so my memorybacking configuration was
>  <memoryBacking>
>     <hugepages>
>       <page size='1048576' unit='KiB' nodeset='1'/>
>     </hugepages>
>     <nosharepages/>
>     <locked/>
>   </memoryBacking>
> i had to remove it completely in order to make it work.
>
> So confirming that hugepages and vfio has some issue, making VM to hang in
> case of linux at startup and abruptly crashing from FreeBSD guest during
> startup.

Can you see if the problem persists with updated QEMU from virt-preview:

https://fedoraproject.org/wiki/Virtualization_Preview_Repository

2MB hugepages certainly works, I run it daily.  1GB hugepages sees less
attention, but I certainly thought it worked as well.  Thanks,

Alex



--
-chintu-


_______________________________________________
vfio-users mailing list
vfio-users redhat com
https://www.redhat.com/mailman/listinfo/vfio-users




--
-chintu-

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]