[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[vfio-users] gpu passthrough problems after upgrade qemu 2.5 -> 2.6



Hello,

yesterday I've upgraded to qemu 2.6 (I've just rebuilt debian sid
package for jessie, previously I did the same with 2.5 and just added
input-linux patches).

I'm using vga passthrough on HP Elitebook 8560p laptop with Radeon HD
6470M, passing it in with x-vga=on (no ovmf, it doesn't have ovmf firmware)

After the upgrade, when booting linux, it shows bios screen, then
alternates black and garbage screen for few minutes, then reboots (?),
bios screen again, black screen, linux (only after driver kicks in, no
grub/boot screen, previously it worked). Rebooting from guest makes it
go through this all again including the few minutes of garbage sreens.
There's nothing in guest logs for that time, likely it doesn't even pass
grub.

For windows it actually boots on first attempt, but also no output until
driver kicks in (previosly it shown boot screen or worked without ati
drivers installed)

in the dmesg, there's quite a lot of rdmsr errors (on 2.5 there few a
few too, but they appeared once, not in multiple batches like now).

I assume some graphic modes are now handled differently. Is it only a
change in defaults that I can override or is it a bug?

dmesg:
[  136.888758] e1000e 0000:00:19.0: irq 46 for MSI/MSI-X
[  136.992866] e1000e 0000:00:19.0: irq 46 for MSI/MSI-X
[  136.993181] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[  140.329803] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow
Control: None
[  140.329858] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  148.661906] VFIO - User Level meta-driver version: 0.3
[  148.667113] ehci-pci 0000:00:1a.0: remove, state 1
[  148.667123] usb usb3: USB disconnect, device number 1
[  148.667126] usb 3-1: USB disconnect, device number 2
[  148.667128] usb 3-1.1: USB disconnect, device number 3
[  148.667327] usb 3-1.2: USB disconnect, device number 4
[  148.667931] cdc_ncm 3-1.2:1.6 usb0: unregister 'cdc_ncm'
usb-0000:00:1a.0-1.2, CDC NCM
[  148.701340] ehci-pci 0000:00:1a.0: USB bus 3 deregistered
[  148.876484] ehci-pci 0000:00:1d.0: remove, state 1
[  148.876505] usb usb4: USB disconnect, device number 1
[  148.876512] usb 4-1: USB disconnect, device number 2
[  148.876517] usb 4-1.1: USB disconnect, device number 3
[  148.986636] usb 4-1.4: USB disconnect, device number 4
[  149.045785] usb 4-1.6: USB disconnect, device number 5
[  149.055202] ehci-pci 0000:00:1d.0: USB bus 4 deregistered
[  149.099334] xhci_hcd 0000:05:00.0: remove, state 4
[  149.099348] usb usb2: USB disconnect, device number 1
[  149.116629] xhci_hcd 0000:05:00.0: USB bus 2 deregistered
[  149.116699] xhci_hcd 0000:05:00.0: remove, state 4
[  149.116710] usb usb1: USB disconnect, device number 1
[  149.118085] xhci_hcd 0000:05:00.0: USB bus 1 deregistered
[  149.408028] IPv6: ADDRCONF(NETDEV_CHANGE): br0vmtap10: link becomes ready
[  149.408081] br0: port 1(br0vmtap10) entered forwarding state
[  149.408092] br0: port 1(br0vmtap10) entered forwarding state
[  149.408305] IPv6: ADDRCONF(NETDEV_CHANGE): br1vmtap10: link becomes ready
[  149.408333] br1: port 1(br1vmtap10) entered forwarding state
[  149.408343] br1: port 1(br1vmtap10) entered forwarding state
[  151.128482] vfio_cap_init: 0000:00:1a.0 hiding cap 0xa
[  151.232527] vfio_ecap_init: 0000:00:1b.0 hiding ecap 0x5 0x130
[  151.340394] vfio_cap_init: 0000:00:1d.0 hiding cap 0xa
[  156.620596] dmar: DRHD: handling fault status reg 3
[  156.620662] dmar: DMAR:[DMA Read] Request device [00:1d.0] fault addr
ef000
DMAR:[fault reason 06] PTE Read access is not set
[  157.585018] kvm: zapping shadow pages for mmio generation wraparound
[  164.431957] br0: port 1(br0vmtap10) entered forwarding state
[  164.431966] br1: port 1(br1vmtap10) entered forwarding state
[  243.766285] kvm [4369]: vcpu0 unhandled rdmsr: 0x606
[  243.766358] kvm [4369]: vcpu0 unhandled rdmsr: 0x34
[  244.095770] vfio-pci 0000:05:00.0: irq 47 for MSI/MSI-X
[  244.149600] vfio-pci 0000:05:00.0: irq 47 for MSI/MSI-X
[  244.149606] vfio-pci 0000:05:00.0: irq 48 for MSI/MSI-X
[  244.149828] vfio-pci 0000:05:00.0: irq 47 for MSI/MSI-X
[  244.149832] vfio-pci 0000:05:00.0: irq 48 for MSI/MSI-X
[  244.149835] vfio-pci 0000:05:00.0: irq 49 for MSI/MSI-X
[  245.276448] kvm [4369]: vcpu0 unhandled rdmsr: 0x611
[  245.276518] kvm [4369]: vcpu0 unhandled rdmsr: 0x639
[  245.276582] kvm [4369]: vcpu0 unhandled rdmsr: 0x641
[  245.276644] kvm [4369]: vcpu0 unhandled rdmsr: 0x619
[  245.438562] vfio-pci 0000:00:1b.0: irq 50 for MSI/MSI-X
[  245.499553] vfio-pci 0000:01:00.1: irq 51 for MSI/MSI-X
[  245.608806] vfio-pci 0000:01:00.0: irq 54 for MSI/MSI-X
[  577.967787] kvm [4369]: vcpu0 unhandled rdmsr: 0x606
[  577.967861] kvm [4369]: vcpu0 unhandled rdmsr: 0x34
[  578.306848] vfio-pci 0000:05:00.0: irq 47 for MSI/MSI-X
[  578.357705] vfio-pci 0000:05:00.0: irq 47 for MSI/MSI-X
[  578.357712] vfio-pci 0000:05:00.0: irq 48 for MSI/MSI-X
[  578.357855] vfio-pci 0000:05:00.0: irq 47 for MSI/MSI-X
[  578.357859] vfio-pci 0000:05:00.0: irq 48 for MSI/MSI-X
[  578.357863] vfio-pci 0000:05:00.0: irq 49 for MSI/MSI-X
[  579.069686] kvm [4369]: vcpu0 unhandled rdmsr: 0x611
[  579.069757] kvm [4369]: vcpu0 unhandled rdmsr: 0x639
[  579.069822] kvm [4369]: vcpu0 unhandled rdmsr: 0x641
[  579.069885] kvm [4369]: vcpu0 unhandled rdmsr: 0x619
[  579.197944] vfio-pci 0000:00:1b.0: irq 50 for MSI/MSI-X
[  579.251914] vfio-pci 0000:01:00.0: irq 51 for MSI/MSI-X
[  581.257044] vfio-pci 0000:01:00.1: irq 54 for MSI/MSI-X

Thanks,
Gh.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]